Upgraded to the latest Skype Linux version but getting blank screen

Upgraded to the latest Skype Linux version only to find out it doesn't work for Linux Mint 18, I am getting a blank screen after launching. How do I fix this? How do I downgrade to the previous Skype Linux version?
 

Question Info


Last updated May 12, 2019 Views 10,566 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi,

 

Linux Mint 18, is not supported by Skype, for your reference about the distribution, we support for Linux, check this link: https://support.skype.com/en/faq/FA10328/

You can, completely uninstall and reinstall the Skype application and kindly test the application.

 

If the issue still persists, do not hesitate to contact us back.

 

Marites P

 

Skype Community Moderator

Marites P

Skype Community Moderator

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have the same problem with Ubuntu 16.04.3 LTS.

8 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

The same problem with Debian Stretch

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have the same problem with Skype on Linux Mint 18.2 Cinnamon 64bit.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Me too.

Ubuntu 17.04

Trying to launch it by terminal:

$ /usr/share/skypeforlinux/skypeforlinux
ALSA lib pcm.c:2495:(snd_pcm_open_noupdate) Unknown PCM mic_call
ALSA lib pcm.c:2495:(snd_pcm_open_noupdate) Unknown PCM call
ALSA lib pcm.c:2495:(snd_pcm_open_noupdate) Unknown PCM mic_call
ALSA lib pcm.c:2495:(snd_pcm_open_noupdate) Unknown PCM call
ALSA lib pcm.c:2495:(snd_pcm_open_noupdate) Unknown PCM mic_call
ALSA lib pcm.c:2495:(snd_pcm_open_noupdate) Unknown PCM call

--------- skype window and content are visible -------

Server response: <?xml version="1.0" encoding="UTF-8"
--------- after receiving this server response, the skype window become blank  -------

5 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have the same problem, a blank window an nothing works.

My computer is a Intel 64 bit with Debian 9 and the XFCE4 gui.

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi All,

Currently Linux Mint is not supported by Skype. You can check this link: https://support.skype.com/en/faq/FA10328/ about the Skype Linux system requirements.

Should you have further questions, do not hesitate to contact us back.

Marites P

Skype Community Moderator

Marites P

Skype Community Moderator

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

What do you mean not supported? It has been officially released, as I see on the Microsoft website, and it is listed on the system requirements list. My system, Debian 9.1 Stretch, is included in the Sys req list ("64-bit Debian 8.0+") and I still have the same issue. Blank window, not responding, having to kill it every time I try to launch Skype.

8 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi All,

Currently Linux Mint is not supported by Skype. You can check this link: https://support.skype.com/en/faq/FA10328/ about the Skype Linux system requirements.

Should you have further questions, do not hesitate to contact us back.

Marites P

Skype Community Moderator

It might help to know that Linux Mint is basically Ubuntu (a derivative of it using its repositories), so this answer is not very helpful at all but rather an excuse to ignore a glaring problem. 

Also note, that people using Debian, Ubuntu (yes, the Ubuntu) and other "officially supported" distributions are experiencing the same problems. Yours truly is having it on Linux Mint 18.2 KDE. A fix would be very much appreciated. If it's fed to the Ubuntu repositories I'm sure it will miraculously also reach Mint users...

11 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

It work fine with my Mint 18.2 Cinnamon. Something missing from certain distros but it could work for different configurations of the same distribution. While Arch is not "officially" supported they fix it today on my Manjaro Xfce 17 with a new version (8.10.76.7). So I guess they are working on it. Limiting Skype to certain distros is non-sense.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.