System tray icon in xfce

Am I the only one who is experiencing a weird system tray icon in xfce?

With the previous skype version (8.x, latest version until today), I had a small skype icon, which I could live with, but it was still annoying.

Now with the latest version, 8.20.76.1, this small icon started repeating. It's even more annoying than before.

My setup is as follows:

Debian Linux 9 (stretch)

xfce4 4.12.3

skypeforlinux 8.20.76.1

This is on a 27" monitor with a resolution of 2560x1440

 

Question Info


Last updated November 14, 2018 Views 3,738 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi free6,

Can you please try to uninstall, reboot, and reinstall the Skype app on your device? Then check if the Skype app is still overlapping on the interface.

I look forward to your reply.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Kenneth

I've tried this but nothing changed.

Is the system tray icon bundled in the electron app, or is it taken from the /usr/share/icons/hicolor/.... ?

Those icons, which are installed by skypeforlinux, have a "preview" written across the skype logo.  The system tray icon does not.  That's why I'm asking, in case maybe it's taking the wrong icon from who-knows-where?

Thanks for the help!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi free6,

Can you please try to uninstall all the Skype files? It is possible that the old Skype app is still installed to your device.

Let me know if that works.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This exact same icon problem also started happening for me since 8.20.76.1 on Arch Linux running GNOME. Also in 8.20.76.3 and current 8.20.76.8.

This guy also reports the same problem in another thread here: https://answers.microsoft.com/en-us/skype/forum/skype_linux-skype_startms-skype_installms/issue-with-skype-tray-icon-starting-with-version/82dcc7bb-cd51-4d31-a843-e8cc949564e6

I concur with what free6 is saying. All the PNG files bundled in the deb file have a either a P or a Preview emblazened across them but the small icon we are seeing the the system tray does not. So it does not seem to be coming from any explicit image file bundled in the deb. Please moderators here, appreciate what we are saying here and don't just tell us to "reinstall". This is affecting multiple (possibly all?) Linux users since 8.20.76.1.

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Guy from the other thread here. Thanks for making me aware of this thread.

Same problem as the other people here, re-installing Skype fixes nothing. Every version of Skype after 8.20.76.1 has the problem, whereas all versions before that work fine (but of course bug you to update all the time).

So the problem shows in xfce, GNOME and Budgie (the latter being my case). Seems like every desktop environment is affected (unless others like KDE handle things in a very different way). This has kept us from updating the Skype version for Solus, because a constant update notification is less annoying than a broken tray icon.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi free6,

Can you please try to uninstall all the Skype files? It is possible that the old Skype app is still installed to your device.

Let me know if that works.

Hi Kenneth,

This made no difference whatsoever.

Since more people are having this issue, I think you guys should really try to find a solution, because it makes Skype the only application that looks like crap in the system tray - not good for business :-)

I did a tiny bit of research on this and I think it might be related to an Electron issue.  These guys seem to be having a similar problem: https://github.com/meetfranz/franz/issues/233#issuecomment-358488534

Hopefully you guys can reproduce this and solve it.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi All,

Have you tried reinstalling a lower version of Skype?

I look forward to your reply!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi All,

Have you tried reinstalling a lower version of Skype?

I look forward to your reply!

I haven't, but it never looked good with older versions for me either.  It was similar to how it looks now, wrong height, all scrunched up in the top there, but it wasn't repeating.  Now it starts to repeat the icon and it looks even worse.

By older version I'm assuming you mean "new skype, old version", so like 8.x, and not skype 4.x...

Here's another funny thing, when I change the status, I start to get some funny green stuff below the icon which doesn't go away until I restart skype... as if it's starting to show the next image from a sprite or something.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi All,

Have you tried reinstalling a lower version of Skype?

I look forward to your reply!

Yes, all versions before 8.20.76.1 work fine, every version after that (including 8.20.76.1) shows the issue.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Here's another funny thing, when I change the status, I start to get some funny green stuff below the icon which doesn't go away until I restart skype... as if it's starting to show the next image from a sprite or something.

Have you tried the newest version (8.20.76.8)? I saw the same thing before, but I can't reproduce it anymore with the new version. Well, it's not the main problem anyway.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.