Skype for Linux 8.20.x.x doesn't start on Debian 9/10 / OpenSUSE

Beginning from version 8.20.0.9 the skypeforlinux command does not have any effect. No output on the console is returned.
The following error message is reported in the log file:

skype-startup.log:

dbus[24621]: dbus message iterator has already been closed, or is uninitialized or corrupt
  D-Bus not built with -rdynamic so unable to print a backtrace
Server response: <?xml version="1.0" encoding="UTF-8"

Any way around this?

Thanks, René

 

Question Info


Last updated December 3, 2018 Views 1,436 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Same problem here: 8.18.0.6 works fine, but anything newer segfaults. Both .deb and snap releases are affected.

System:

Ubuntu 16.04.4 LTS (fully updated).

DE: Xfce

Terminal output:

Server response: <?xml version="1.0" encoding="UTF-8"
Segmentation fault

dmesg:

[  794.572869] skypeforlinux[25928]: segfault at 8 ip 00007ff86e2a8600 sp 00007ffcd67cdd48 error 4 in libdbus-1.so.3.14.6[7ff86e292000+4a000]

bracktrace:

Thread 1 "skypeforlinux" received signal SIGSEGV, Segmentation fault.
0x00007ffff491b600 in _dbus_header_get_byte_order () from /lib/x86_64-linux-gnu/libdbus-1.so.3
(gdb) bt
#0  0x00007ffff491b600 in _dbus_header_get_byte_order () from /lib/x86_64-linux-gnu/libdbus-1.so.3
#1  0x00007ffff4920469 in ?? () from /lib/x86_64-linux-gnu/libdbus-1.so.3
#2  0x00007ffff49211e9 in dbus_message_iter_get_arg_type () from /lib/x86_64-linux-gnu/libdbus-1.so.3
#3  0x000000000215d8d9 in ?? ()
#4  0x000000000215ba0c in ?? ()
#5  0x0000000004e817b5 in atom::PowerObserverLinux::OnInhibitResponse(base::ScopedGeneric<int, base::internal::ScopedFDCloseTraits>*, dbus::Response*) ()
#6  0x000000000215ee40 in ?? ()
#7  0x00000000021618c0 in ?? ()
#8  0x000000000215f2c6 in ?? ()
#9  0x0000000002161c9f in ?? ()
#10 0x00000000047ece4b in ?? ()
#11 0x00000000047da63b in ?? ()
#12 0x00000000047da958 in ?? ()
#13 0x00000000047dad31 in ?? ()
#14 0x00000000047b0db9 in ?? ()
#15 0x000000000479cc20 in ?? ()
#16 0x0000000001bf4f9e in ?? ()
#17 0x0000000001bf4d9e in ?? ()
#18 0x0000000001d5bead in ?? ()
#19 0x0000000001e5db93 in ?? ()
#20 0x0000000001a4263c in ?? ()
#21 0x00000000019dcd0d in ?? ()
---Type <return> to continue, or q <return> to quit---
#22 0x0000000001a42f92 in ?? ()
#23 0x0000000004d9abad in main ()

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hello René,

 

 

Kindly uninstall and reinstall the Skype application and let us know of the results.

 

 

We will wait for your reply.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have the same problem with skypeforkinux above 8.2x on opensuse Tumbleweed. However, I can start it with  superuser terminal, but not as ordinary user. I have tried to uninstall and reinstall several times, also delete ~/.config/skypeforlinux without any result. I have also tried the work around from here: skypeforlinux still not workingIt did not help either. It seems to me that all this is caused by a mess with some permissions. Interestingly,  skype 8.22.. works without problems on my MX-linux based on Debian 9.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hello DenSp,

Please check your inbox. I have sent you a private message on how to proceed.

Regards,

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have the exact same problem as DenSp.

On one system, it works normally, on the other system, skypeforlinux only starts correctly when started as a superuser.

Is there any solution?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hello Turucano,

Do you have the latest Skype version installed (v8.24)? If not, kindly do an update and let us know of the results: Skype Downloads.  

Looking forward to your reply.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Yes, the installed version is 8.24.0.2

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hello Turucano,

I will be referring you to our live chat support for better assistance. Kindly check your inbox.

Thank you.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Same problem here with latest skype downloaded today 8.24.0.2 and debian 9.4 - only works as root, way too risky to run like that.

not sure why the solutions are being proffered via private email - shouldnt the public get to know too? I wouldnt be writing this reply in that case.....

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I am having similar problems: I am running on debian 9.4 with skypeforlinux 8.25.0.5 and Skype is stuck on a blank screen after I entered my password. When I run Skype as root, everything works as expected.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.