Skype doesn't open after updating to version 8.44.0.40-1 on CentOS7 64b

I was using Skype on this computer (CentOS Linux 7 64b) for almost 6 months already, with no issues.

But after the updates of this morning (6th/May/2019) to the version 8.44.0.40-1, the Skype is not opening anymore.

I've already tried to restart, update, kill the processes and reopen, Launch by Application Installer, but nothing worked.

 

Question Info


Last updated September 15, 2019 Views 779 Applies to:
I have the same issue but in windows 10 64-bit. Skype is not working anymore after update.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Marcel

I'm so sorry you are facing issues!
My name is Margarida, I'm an Independent Advisor.

It could be because CentOS is not one of the Linux versions under Skype's System requirements list (https://support.skype.com/en/faq/fa10328/what-a...). The ones included are:
64-bit Ubuntu 14.04+
64-bit Debian 8.0+
64-bit OpenSUSE 13.3+
64-bit Fedora Linux 24+

If you roll back to the previous version, does it work?

Thank you, have a great week!
Margarida

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have the same problem.  What to do?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

If you cat ~/.config/skypeforlinux/logs/skype-startup.log you will see:

A JavaScript error occurred in the main process
Uncaught Exception:
Error: /lib64/libc.so.6: version `GLIBC_2.18' not found (required by /usr/share/skypeforlinux/resources/app.asar.unpacked/node_modules/slimcore/bin/sharing-indicator.node)
    at process.module.(anonymous function) [as dlopen] (ELECTRON_ASAR.js:166:20)
    at Object.Module._extensions..node (internal/modules/cjs/loader.js:740:18)
    at Object.module.(anonymous function) [as .node] (ELECTRON_ASAR.js:180:18)
    at Module.load (internal/modules/cjs/loader.js:620:32)
    at tryModuleLoad (internal/modules/cjs/loader.js:559:12)
    at Function.Module._load (internal/modules/cjs/loader.js:551:3)
    at Module.require (internal/modules/cjs/loader.js:658:17)
    at require (internal/modules/cjs/helpers.js:20:18)
    at Object.<anonymous> (/usr/share/skypeforlinux/resources/app.asar/node_modules/slimcore/lib/sharing-indicator.js:1:173)
    at Object.<anonymous> (/usr/share/skypeforlinux/resources/app.asar/node_modules/slimcore/lib/sharing-indicator.js:3:3)

so it appears that they are indeed requiring a newer operating system and not supporting EL7 (it has glibc 2.17).  For now, downgrading to 8.34.0.78 seems to be the way to go.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.