MSE prompt for .msi files during install

Hello there,
I'm using windows 7 professional 64-bit polish version.

For the last 6 months MSE was working without any problems (save for rare instances when automatic protection was turning itself off and it was impossible to change it without reset). Today I ran Windows Update and during the process I was prompted for .msi files. Few of those files were located in the instalation folder of MSE, others I couldnt find, so I canceled instalation and restarted system (I was also instaling other updates, so I had to anyway). Since MSE wasnt starting after reboot I uninstaled it (without problems). I downloaded newest version from: www.microsoft.com/pl-pl/security_essentials/default.aspx and during the instalation process I'm again asked from .msi files (first file epploc_amd64.msi is inside temporary folder, but even thou I select it manualy, instaler is rejecting it).
I used automated cleanup script from: http://support.microsoft.com/kb/2483120/pl and run cccleaner + regedit aswell to get rid of any MSE leftovers, however problem persists.

Any help will be appreciated!


 

Question Info


Last updated May 16, 2018 Views 542 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

After more intense cleaning of MSE remnants problem evolved - instaler is no longer asking for files, just throwing 0x80070645 error.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Check this post

http://answers.microsoft.com/en-us/protect/forum/protect_start/error-code-0x80070645-when-installing-security/02415eb9-68df-4e09-bb6b-72fa4095bce3

If that does not help, do a search for 0x80070645 in this forum

There are a lot more solutions out there.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

--
~Robear Dyer (PA Bear)
Microsoft MVP (Windows Client) since October 2002

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I think I did everything mentioned in other threads:

1) downloaded and applied this fix: http://support.microsoft.com/kb/2435760
2) searched registry for anything with: "essentials", "security client", "antimalware".
3) searched registry for 1F69ACF0D1CF2B7418F292F0E05EC20B "upgradecode" key (it was not there btw).
4) deleted folders.




here's instal log (errors bolded):


START    2011/10/23 00:31:36:397 TID:1320 PID:1740

INFO    2011/10/23 00:31:36:397 TID:1320 PID:1740
Log location [D:\root\ProgramData\Microsoft\Microsoft Security Client\Support]

ERROR    2011/10/23 00:31:36:397 TID:1320 PID:1740
Operation failed: Start WPP logging - Can't complete the Setup Wizard. An error has prevented Setup Wizard from continuing. Please restart your computer and try again. Error code:0x80070020. (null) [80070020]

INFO    2011/10/23 00:31:36:397 TID:1320 PID:1740
Initializing WPP Logging with APP NAME[MSSESetup]

SUCCESS    2011/10/23 00:31:36:397 TID:1320 PID:1740
Starting setup...

INFO    2011/10/23 00:31:36:399 TID:1320 PID:1740
Current version number is '2.1.1116.0'

INFO    2011/10/23 00:31:36:399 TID:1320 PID:1740
Command line arguments: []

INFO    2011/10/23 00:31:36:399 TID:1320 PID:1740
Setup type is 0x2

INFO    2011/10/23 00:31:36:404 TID:1320 PID:1740
Market set to 'pl-pl'

INFO    2011/10/23 00:31:36:409 TID:1320 PID:1740
Internal brand name is 'MSEv2'

INFO    2011/10/23 00:31:36:409 TID:1320 PID:1740
Processor Architecture: amd64

INFO    2011/10/23 00:31:36:409 TID:1320 PID:1740
OS type: 16

INFO    2011/10/23 00:31:36:409 TID:1320 PID:1740
OS friendly name: Windows 7 Professional

INFO    2011/10/23 00:31:36:409 TID:1320 PID:1740
Attempt to run Install scenario

INFO    2011/10/23 00:31:36:509 TID:1320 PID:1740
Operation finished: MorroBootstraper::CInstallFlow::InternalRun - GetInstallPrequalChecksAction

INFO    2011/10/23 00:31:36:509 TID:1320 PID:1740
Show dialog, ID [1]

INFO    2011/10/23 00:31:37:894 TID:1320 PID:1740
Show dialog, ID [9]

INFO    2011/10/23 00:31:39:323 TID:1320 PID:1740
Show dialog, ID [45]

INFO    2011/10/23 00:31:43:120 TID:1320 PID:1740
Operation finished: MorroBootstraper::CInstallFlow::InternalRun - GetSqmOptInAction

INFO    2011/10/23 00:31:43:120 TID:1320 PID:1740
Show dialog, ID [51]

INFO    2011/10/23 00:31:44:340 TID:1320 PID:1740
Show dialog, ID [52]

INFO    2011/10/23 00:31:44:415 TID:1320 PID:1740
Operation finished: MorroBootstraper::CInstallFlow::InternalRun - GetWmiInfrastructureCheckAction

INFO    2011/10/23 00:31:46:412 TID:1696 PID:1740
Show dialog, ID [34]

INFO    2011/10/23 00:31:47:117 TID:1320 PID:1740
Operation finished: MorroBootstraper::CInstallFlow::InternalRun - GetCompetitiveAppRemoveAction

INFO    2011/10/23 00:31:47:117 TID:1320 PID:1740
Show dialog, ID [2]

INFO    2011/10/23 00:31:47:138 TID:1320 PID:1740
Operation finished: MorroBootstraper::CInstallFlow::InternalRun - GetInstallNisPrequal

INFO    2011/10/23 00:31:47:140 TID:1320 PID:1740
Operation finished: MorroBootstraper::CInstallFlow::InternalRun - GetClientLocUninstallPackage

INFO    2011/10/23 00:31:47:144 TID:1320 PID:1740
Operation finished: MorroBootstraper::CInstallFlow::InternalRun - GetClientUninstallAction

INFO    2011/10/23 00:31:47:147 TID:1320 PID:1740
Operation finished: MorroBootstraper::CInstallFlow::InternalRun - GetAMUninstallAction

INFO    2011/10/23 00:31:47:149 TID:1320 PID:1740
Operation finished: MorroBootstraper::CInstallFlow::InternalRun - GetAMLocUninstallAction

INFO    2011/10/23 00:31:47:149 TID:1320 PID:1740
Operation finished: MorroBootstraper::CInstallFlow::InternalRun - GetUninstallExternalPackagesAction

INFO    2011/10/23 00:31:47:153 TID:1320 PID:1740
Operation finished: MorroBootstraper::CInstallFlow::InternalRun - GetClientLocMUIUninstallAction

INFO    2011/10/23 00:31:47:155 TID:1320 PID:1740
Operation finished: MorroBootstraper::CInstallFlow::InternalRun - GetAMLocMUIUninstallAction

INFO    2011/10/23 00:31:47:177 TID:1320 PID:1740
Operation finished: MorroBootstraper::CInstallFlow::InternalRun - GetCopyFileAction

INFO    2011/10/23 00:31:47:177 TID:1320 PID:1740
Operation finished: MorroBootstraper::CInstallFlow::InternalRun - GetDrWatsonInstallAction

INFO    2011/10/23 00:31:49:212 TID:1320 PID:1740
Operation finished: MorroBootstraper::CInstallFlow::InternalRun - GetClientInstallAction

ERROR    2011/10/23 00:31:49:355 TID:1320 PID:1740
Operation failed: MorroBootstraper::CInstallFlow::InternalRun - GetClientLocInstallPackage - Cannot complete the Security Essentials installation. An error has prevented the Security Essentials setup wizard from completing successfully. Please restart your computer and try again. Error code:0x80070645. (null) [80070645]

INFO    2011/10/23 00:31:49:355 TID:1320 PID:1740
Performing Rollback

INFO    2011/10/23 00:31:49:355 TID:1320 PID:1740
Show dialog, ID [38]

INFO    2011/10/23 00:31:49:377 TID:1320 PID:1740
Operation finished: MorroBootstraper::CInstallFlow::RollbackInstallation - GetBetaUninstallAction

INFO    2011/10/23 00:31:49:377 TID:1320 PID:1740
Operation finished: MorroBootstraper::CInstallFlow::RollbackInstallation - GetUninstallExternalPackagesAction

INFO    2011/10/23 00:31:49:379 TID:1320 PID:1740
Operation finished: MorroBootstraper::CInstallFlow::RollbackInstallation - GetAMLocUninstallAction

INFO    2011/10/23 00:31:51:315 TID:1320 PID:1740
Operation finished: MorroBootstraper::CInstallFlow::RollbackInstallation - GetClientUninstallAction

INFO    2011/10/23 00:31:51:319 TID:1320 PID:1740
Operation finished: MorroBootstraper::CInstallFlow::RollbackInstallation - GetClientLocMUIUninstallAction

INFO    2011/10/23 00:31:51:322 TID:1320 PID:1740
Operation finished: MorroBootstraper::CInstallFlow::RollbackInstallation - GetAMLocMUIUninstallAction

INFO    2011/10/23 00:31:51:324 TID:1320 PID:1740
Operation finished: MorroBootstraper::CInstallFlow::RollbackInstallation - GetClientLocUninstallPackage

INFO    2011/10/23 00:31:51:328 TID:1320 PID:1740
Operation finished: MorroBootstraper::CInstallFlow::RollbackInstallation - GetAMUninstallAction

INFO    2011/10/23 00:31:51:328 TID:1320 PID:1740
Operation finished: MorroBootstraper::CInstallFlow::RollbackInstallation - GetArpUninstallAction

INFO    2011/10/23 00:31:51:328 TID:1320 PID:1740
Operation finished: MorroBootstraper::CInstallFlow::RollbackInstallation - GetDrWatsonUninstallAction

INFO    2011/10/23 00:31:51:360 TID:1320 PID:1740
Show dialog, ID [10]

ERROR    2011/10/23 00:32:09:798 TID:1320 PID:1740
Operation failed: Flow InternalRun - Cannot complete the Security Essentials installation. An error has prevented the Security Essentials setup wizard from completing successfully. Please restart your computer and try again. Error code:0x80070645. (null) [80070645]

ERROR    2011/10/23 00:32:09:798 TID:1320 PID:1740
Operation failed: Setup - Cannot complete the Security Essentials installation. An error has prevented the Security Essentials setup wizard from completing successfully. Please restart your computer and try again. Error code:0x80070645. (null) [80070645]

INFO    2011/10/23 00:32:09:814 TID:1320 PID:1740
Operation finished: Sending setup completed event to event log

INFO    2011/10/23 00:32:09:816 TID:1320 PID:1740
Stopping logging...

FINISH    2011/10/23 00:32:09:816 TID:1320 PID:1740


Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

See the ANSWER post in this related thread => http://answers.microsoft.com/en-us/protect/forum/protect_start/mse-instal-error-code-0x80070645/07b750da-341a-44b6-887f-39c9c11353ed (28 Jan-11 &ff)

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

If still no joy, please answer all of the following diagnostic questions by number in your next reply (no need to quote this post):

1a. When (approx. date) did you purchase the computer?

1b. Did Win7 (64-bit) come preinstalled on the computer when you bought it, did you do a clean install of Win7, or did you upgrade from Vista to Win7?

2. Is Windows 7 Service Pack 1 (already) installed? See...

   • Which version of the Windows operating system am I running?
      http://windows.microsoft.com/en-us/windows7/help/which-version-of-the-windows-operating-system-am-i-running

3. When (approx. date) did you originally (first) install Microsoft Security Essentials (MSE) and was the computer fully-patched at Windows Update at the time?

4. What, if any, anti-virus application was installed before you first installed MSE, was your subscription still current, and did you uninstall it before you installed MSE?

5. Has a(nother) Norton application or a McAfee application EVER been installed on the computer?

6. Did a Norton free-trial or a McAfee free-trial [pick one] come preinstalled on the computer when you bought it? (Doesn't matter if you never used or Activated it.)

7. Are ALL of the following updates listed in View installed updates (not Update History)? [1]

    • KB2586448, KB2567053, KB2570947, KB2616676 & KB2567680

    • KB2572076 or KB2572077 [<=TELL ME WHICH ONE]

    • KB2544521 or Windows Internet Explorer 9 [<=TELL ME WHICH ONE]

==============================================
[1] Start | Control Panel | Programs and Features | View installed updates (in left-hand menu)

--
~Robear Dyer (PA Bear)
Microsoft MVP (Windows Client) since October 2002

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I did everything mentioned in that post:

1) Ran two fix-it scripts
- http://support.microsoft.com/kb/2435760
- http://support.microsoft.com/kb/2483120

2) Searched for mentioned registry keys

HKEY_CLASSES_ROOT\Installer\UpgradeCodes\1F69ACF0D1CF2B7418F292F0E05EC20B

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UpgradeCodes\1F69ACF0D1CF2B7418F292F0E05EC20B


but they were not there. Instead I removed everything else related  (by name) to Security Client, Essentials, Antimalware.


___________________________


1a) Februrary 2011.

1b) I did clean install on factory brand new HDD.

2) Yes.

3) First MSE installation was in februrary 2011 aswell. I'm not sure system was fully patched.
4) I installed Avast, used it for few days (less than week) and removed it before instaling MSE.
5) No.
6) No.
7)
- KB2586448 is not listed
- KB2567053 is listed
- KB2570947 is listed
- KB2616676 is listed
- KB2567680 is listed

- KB2572077 is listed (KB2572076 is not)

- KB2544521 is not listed and since I'm not using Insternet Explorer its not listed aswell.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

KB2544521 is not listed and since [Internet Explorer is not installed, IE9 is] not listed [either].


Then we must assume it's Win7 Professional (64-bit) N Edition.

Once again, please answer the following diagnostic questions by number in your next reply:

1. After you completed the clean install of Win7 64-bit in February 2011, how long was the computer connected to the internet or any local networks (i.e., other computers) before you installed Avast (e.g., less than 30 minutes; more than hour; a few days)?

2. After you completed the clean install of Win7 64-bit in February 2011, which of the following did you do first?

    • Installed Avast;
    • Checked for & installed Windows Updates
    • Restored my data backups (e.g., music; pictures; mail client data; etc.); or...
    • Checked my email account.

3. After you uninstalled Avast, how long was the computer connected to the internet or any local networks (i.e., other computers) before you installed Microsoft Security Essentials (e.g., less than 30 minutes; more than hour; a few days)?

4. What is your default Browser (e.g., Firefox; Chrome)?

5. Are you in the habit of using "Registry cleaners" (e.g., Registry Mechanic; System Mechanic; RegCure; Advanced SystemCare; AVG PC TuneUp; PCTools Optimiser; CCleaner)?

--
~Robear Dyer (PA Bear)
Microsoft MVP (Windows Client) since October 2002

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

1) Less than 24 hours, thats for sure. Since it was 8 months ago and my memory is failing me I cant be more precise, sorry.

2) Windows Update was first, data backups (mostly music) were second.
I'm not 100% certain what was third, but my bet is on Avast installation.

3) less than one hour.

4) Firefox 7.0.1.

5) I'm using up to date CCleaner quite often.


Thanks for the help so far.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Windows Update was first, data backups (mostly music) were second.
I'm not 100% certain what was third, but my bet is on Avast installation.

I'm using up to date CCleaner quite often.


IMHO you would have been much better off installing your anti-virus application first and then installing Windows Updates before doing ANYTHING else online or restoring data backups.

That being said...

1. When you run CCleaner's Cleaner component, is the Windows (tab) | Advanced | Hotfix Uninstallers and/or the Applications (tab) | MS Antimalware option checked?

2. Have you EVER used CCleaner's Registry Cleaner component and if so, do you have backups of ALL the changes you've EVER made?

--
~Robear Dyer (PA Bear)
Microsoft MVP (Windows Client) since October 2002

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

1) Since MSE is uninstalled the option is gone from CCleaner aswell, but if I remember correctly I wasnt using it (according to description it would cause MSE "think" it never scaned computer before). Hotfix Uninstallers option is unavaliable under vista/win7 according to Piriform forums.

2) I'm using it once a week (or after uninstalling "big" software with alot of traces in the registry). I have one registry backup file and re-write it each time.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.