Question

Q: Microsoft Security Essentials icon is missing from Taskbar/System Tray.

Hi, my problem seems to be exactly the same as this previous question i.e. the Microsoft Security Essentials icon is missing from the System Tray (next to the clock).
But that topic is locked so I could not reply there.

I'm running Windows XP SP3 and the icon was there until a few days ago. Windows update has installed stuff automatically but I have made no other changes to the machine that I am aware of.

The previous answer was as follows:

If the icon doesn't appear on the task bar it could be one of two things. Either the Microsoft Security Essentials application has failed to start, resulting in the icon being missing, or it could be that the icon is in fact there but is hidden.

 If the icon is hidden, you can right click on the taskbar and choose Properties. Here you will see an option to "Hide Inactive Icons" which can be unchecked as a test, then click OK. This will display all the icons that are hidden or inactive; please check to see if you see the Microsoft Security Essentials icon appear.

 If not, we can try to launch the application manually to see if it starts. Check the desktop for the Microsoft Security Essentials icon and try to launch it manually. If you receive an error message make sure to write it down. After launching it manually, check again for the icon in the taskbar.

 Lastly, the problem might be that Windows is not configured to launch the Microsoft Security Essentials application when you boot the computer. Click Start then Run, and type MSCONFIG and click OK. Here click on the Startup tab and ensure that Microsoft Security Essentials is listed here and it is checked.

In my situation, none of the above suggestions seem to apply, as
1. MsMpEng.exe is showing as running in Task Manager
2. The icon is not hidden. The box in the task bar preferences is NOT ticked. (I tried ticking it and then unticking it again - no change).
3. I can run the program again from the start menu - The resultant window looks perfectly normal and everything is shown as running fine. But there is still no icon visible in the tray when that window is there.
4. However, out of interest, I cannot see anything that looks like Security essentials or MsMpEng.exe in the Startup tab of MSConfig - As the exe [u]is[/u] running, has it been moved to a different place?

Answer

A:

Hi Andy,

 

There should be an entry in MSCONFIG for MSE. The icon you use in the Start menu.  Right click on it and click on properties to see the location.  it should show the path to a file called msseces.exe.  Make a note of that path.

 

Go to Start / Run and type Regedit and enter.  Go to HKEY_LOCAL_MACHINE\Software\Microsoft\CurrentVersion\Run and click on run to see the entries.  Is there one that references the above file?

 

It should have the name MSC and be a string value and the command should say: "C:\Program Files\Microsoft Security Client\msseces.exe" -hide -runkey exactly as I wrote it with the quotes and spaces.  If the path you noted was different from the path I listed, use the path you noted instead, but otherwise keep the quotes and the extra words with dashes in front of them at the end.  If it exists but is different, then change it as indicated.  If it does not exist, create a new string value under Run with those parameters.

 

Now reboot and see if it works?  If not, then the best bet is to uninstall and re-install MSE:

 

To uninstall MSE, proceed as follows: http://answers.microsoft.com/en-us/protect/forum/protect_start/uninstalling-mse/a63b8c4b-58ed-437e-8086-fa08d80725a4.

 

To re-install, check out this article and follow the procedures: http://answers.microsoft.com/en-us/protect/forum/protect_start/check-list-for-installing-microsoft-security/bf757e6a-e320-4a67-92bc-767e6acb26c4 - but also check out the next paragraph before you begin the download.

 

If you do or ever did have any other AV program installed on your computer (even if you didn't use it), you need to make sure they are all uninstalled and fully removed before you install. To fully remove them, check out this listing of removal toolshttp://social.answers.microsoft.com/Forums/en-US/msestart/thread/407bf6da-c05d-4546-8788-0aa4c25a1f91 or the listing in that article at the bottom under troubleshooting steps (why this link isn't at the top near things to do first where it discusses removing all the prior and current AV programs is beyond me) or, if not on the lists, go to the website of the AV software and get and use the removal tool for that product.

 

To install, go to http://www.microsoft.com/en-us/security_essentials/default.aspx and click on languages and locales at the bottom of the Download button and then choose your language and the appropriate version for your operating system.  When you download, save it to the desktop (rather than running it).  When finished, right click on the installation icon and click run as Administrator (even if you’re logged in as an administrator) as I’ve found this sometimes helps.

 

Hopefully, one of these solutions (or a step in one of these answers) will resolve the problem. If not, then open a support case describing the problem starting at:https://support.microsoftsecurityessentials.com/.

 

I hope this helps.

 

Good luck!

MVP(7/2012-6/2015),MCSE,MCSA,MCC2011,xCMM,xCAM,A+,Net+,Security Expert, xInfluencer. See Profile.

W10Prox64 Fast 16299rs3; Ofc Insider 1710/8613.1000; Edge,IE11,Chrome.

Did this solve your problem?

Sorry this didn't help.

14 people were helped by this reply



 
Question Info

Views: 61,354 Last updated: July 10, 2018 Applies to: