Windows Defender not working after upgrade to Windows 8.1

I have Windows 8.1 x64. This was upgraded using the AppStore update from fresh install of Windows 8 x64.

When i turn on windows defender from security center, it just opens the system32 folder.
If i try to turn on the defender service, i get a 577 error as shown

How can i reinstall defender?

(I was using Comodo Internet Security while the upgrade happened but now i have uninstalled it).
Answer
Answer
Thanks Prakash,

I already tried that, should have mentioned in my question earlier.
Sfc finds no errors.

As for the Referesh & Rest option, i am afraid i will loose my office installation activation and it may not work again.

I resolved the issue by following using help from some other thread from these forum using these instrucitons:
I opened up regedit and navigated to the policies for Windows Defender. Changed the permisssions for this folder and added administrators to it.
Then i changed the two entries (DisableAntiSpyware and DisableAntiVirus) to "0" instead of "1".
Then i manually opened the "MSASCui" from "C:\Program Files\Windows Defender" and Defender opened :)

Now i am thinking if there woud be any negative effects of changing permissions of that registry folder and the values as stated above.

30 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 
 

Question Info


Last updated March 9, 2020 Views 16,436 Applies to: