How to disable outgoing e-mail scan in windows defender

I have Windows OS 8. And Microsoft Outlook.
I am having two issues, not sure if they are related. First I am receiving Microsoft. Net Framework unhandled exception errors.
And secondly  I am unable to send e-mails through my software program Sage.
I was told to disable outgoing e-mail scans and I don't know how to do that. I did exclude the  files from that above software program but that has not helped.
Thanks
 

Question Info


Last updated October 9, 2018 Views 2,469 Applies to:

I yesterday, switch on Windows Defender on Windows 10 (next to my Eset Nod32).

Than I get errors sending mails. Switching of Windows Defender solved the problem, so it seems it's a Windows Defender issue!!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I think that it might be due to your security settings within Outlook itself preventing programmatic access to your mail.

"System.Deployment.Application.TrustNotGrantedException: User has refused to grant required permissions to the application."

 

I recommend that you post to the Office forum area for Outlook. Alternatively, you can move this question/discussion to that forum by editing your original post and changing the selection from Virus& Malware to Office and then selecting the version and Outlook.

Be sure to change your subject if you choose to move it. I didn't move the question as I'm not sure what the issue is, but I know it isn't Defender.

 

One would think that Sage has run into this before if it is a permissions issue in Outlook.

 

-steve

^_^
Windows Insider MVP (Security), Moderator Microsoft Community

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Would this be helpful. I receive the below Microsoft.Net Framework error


See the end of this message for details on invoking 
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.Deployment.Application.TrustNotGrantedException: User has refused to grant required permissions to the application.
   at System.Deployment.Application.ApplicationTrust.RequestTrust(SubscriptionState subState, Boolean isShellVisible, Boolean isUpdate, ActivationContext actCtx, TrustManagerContext tmc)
   at System.Deployment.Application.DeploymentManager.DetermineTrustCore(Boolean blocking, TrustParams tp)
   at System.Deployment.Application.DeploymentManager.DetermineTrust(TrustParams trustParams)
   at System.Deployment.Application.ApplicationDeployment.CheckForUpdateBindCompletedEventHandler(Object sender, BindCompletedEventArgs e)


************** Loaded Assemblies **************
mscorlib
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.6400 (Win8RTMGDR.050727-6400)
    CodeBase: file:///C:/Windows/Microsoft.NET/Framework64/v2.0.50727/mscorlib.dll
----------------------------------------
SageExchange
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///C:/Users/Schneider/AppData/Local/Apps/2.0/QWH9J11Y.59H/XW1880N9.MAA/sage..tion_7ed87dda14c1f21d_0001.0000_5a5e5ae73640fc00/SageExchange.exe
----------------------------------------
System.Windows.Forms
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.6402 (Win8RTMGDR.050727-6400)
    CodeBase: file:///C:/windows/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.6401 (Win8RTMGDR.050727-6400)
    CodeBase: file:///C:/windows/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Drawing
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.6401 (Win8RTMGDR.050727-6400)
    CodeBase: file:///C:/windows/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
SPSNet.BaseForms
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///C:/Users/Schneider/AppData/Local/Apps/2.0/QWH9J11Y.59H/XW1880N9.MAA/sage..tion_7ed87dda14c1f21d_0001.0000_5a5e5ae73640fc00/SPSNet.BaseForms.DLL
----------------------------------------
SpsModuleSdkCL
    Assembly Version: 1.0.0.2
    Win32 Version: 1.0.0.2
    CodeBase: file:///C:/Users/Schneider/AppData/Local/Apps/2.0/QWH9J11Y.59H/XW1880N9.MAA/sage..tion_7ed87dda14c1f21d_0001.0000_5a5e5ae73640fc00/SpsModuleSdkCL.DLL
----------------------------------------
RegistryCL
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///C:/Users/Schneider/AppData/Local/Apps/2.0/QWH9J11Y.59H/XW1880N9.MAA/sage..tion_7ed87dda14c1f21d_0001.0000_5a5e5ae73640fc00/RegistryCL.DLL
----------------------------------------
SPSNet.Forms.ApplicationSettings
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///C:/Users/Schneider/AppData/Local/Apps/2.0/QWH9J11Y.59H/XW1880N9.MAA/sage..tion_7ed87dda14c1f21d_0001.0000_5a5e5ae73640fc00/SPSNet.Forms.ApplicationSettings.DLL
----------------------------------------
SPSNet.Libraries
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///C:/Users/Schneider/AppData/Local/Apps/2.0/QWH9J11Y.59H/XW1880N9.MAA/sage..tion_7ed87dda14c1f21d_0001.0000_5a5e5ae73640fc00/SPSNet.Libraries.DLL
----------------------------------------
System.Deployment
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.6387 (Win8RTM.050727-6300)
    CodeBase: file:///C:/windows/assembly/GAC_MSIL/System.Deployment/2.0.0.0__b03f5f7f11d50a3a/System.Deployment.dll
----------------------------------------
DeviceCL
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///C:/Users/Schneider/AppData/Local/Apps/2.0/QWH9J11Y.59H/XW1880N9.MAA/sage..tion_7ed87dda14c1f21d_0001.0000_5a5e5ae73640fc00/DeviceCL.DLL
----------------------------------------
System.Configuration
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.6387 (Win8RTM.050727-6300)
    CodeBase: file:///C:/windows/assembly/GAC_MSIL/System.Configuration/2.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
System.Xml
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.6387 (Win8RTM.050727-6300)
    CodeBase: file:///C:/windows/assembly/GAC_MSIL/System.Xml/2.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
System.Runtime.Remoting
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.6387 (Win8RTM.050727-6300)
    CodeBase: file:///C:/windows/assembly/GAC_MSIL/System.Runtime.Remoting/2.0.0.0__b77a5c561934e089/System.Runtime.Remoting.dll
----------------------------------------
SPSNet.BaseControls
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///C:/Users/Schneider/AppData/Local/Apps/2.0/QWH9J11Y.59H/XW1880N9.MAA/sage..tion_7ed87dda14c1f21d_0001.0000_5a5e5ae73640fc00/SPSNet.BaseControls.DLL
----------------------------------------
System.Security
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.6404 (Win8RTMGDR.050727-6400)
    CodeBase: file:///C:/windows/assembly/GAC_MSIL/System.Security/2.0.0.0__b03f5f7f11d50a3a/System.Security.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
    <system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.


Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thank you for your reply Steve, at least now I can rule out that theory. Still looking for the solution as to why my accounting software will not send out e-mails as it should. Tech support from their end claims it is a Microsoft issue and not theirs.  ??? Back to the drawing board. Again thanks for ruling that one out. If you have any other ideas I would love to hear them. Thanks, Lisa

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Windows Defender does not scan emails on sending or receiving like some other antivirus programs.  Your problem would not be with Defender.

 

-steve

^_^
Windows Insider MVP (Security), Moderator Microsoft Community

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.