Q: Can't install Microsoft Security Essentials, error code 0x80070643 This thread is locked from future replies

Some false internet security program started to run.  My husband didn't close the window properly (I guess) and MSE stopped working.  I did a restore point first.  The restore succeeded but MSE still didn't work.  I tried to uninstall and reinstall MSE.  Couldn't do it in the typical manner (programs > unintall).  So I downloaded Malwarebytes which found and removed some trojan.  Still couldn’t uninstalI MSE.  I was finally able to remove MSE using Microsoft article at  But I have not been able to reinstall MSE.  I even removed Malwarebytes in case it was the problem - conflicting AV software - even though I run both on my other computer.  Then I went through all the steps in  Error code is 0x80070643. 


One answer in this forum told me that maybe I needed to run updates in windows.  I can't run updates either -- I think that error code was 0x80070002.  Even the windows update troubleshooter couldn't fix it. 


Any help would be greatly appreciated. 



I tried everything suggested above in this post.  In the meantime, I received a reply to my request for help at  The few times I've had a problem, has solved the problem relatively quickly.  However, this problem even stumped them.  I spent a whole week going back and forth with them.  In the end, I had to do a system recovery back to the factory settings.  Within a few hours, I had most of my programs and files back on.  I wish I would have just done the system restore from the beginning.

Did this solve your problem?

Sorry this didn't help.

1 person was helped by this reply

Question Info

Views: 21,381 Last updated: March 10, 2018 Applies to: