How do I turn off AntiMalware Service Executable

I need to turn off this process, this program alone is taking up 20% of my memory doing nothing, I have 8 GB of RAM and I really don't care for this process. How do I turn it off. I have tried making an exclusion in the windows defender settings, and I have tried editing the registry files for this service but I still won't stop or at least use less memory. How do i turn it off?
|

Hi Oscar,

AntiMalware Service Executible is your antivirus protection.

If you want to stop it, you should install some other antivirus program.

Another antivirus program will disable Windows Defender, and you should

not have to take any further action, to keep it from running. However, it is integral

with Windows, and you cannot remove the program from Windows.

On my PC this program occupies about 200 MB. Only around 260 MB while scanning.

That is miniscule, when compared with 8 GB.     If yours occupies much more than

mine, that would be suspect. Is yours much larger than mine? 

On another PC, that uses Avast, Antimalware Service Executible only consumes 5 MB.  

Regards,  Glen

8 people found this reply helpful

Was this reply helpful?

Yes
No

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hello Oscar

Antimalware Service Executable high memory usage complaints have increased after Windows 10 update. It is an integral part of the program (MsMpEng.exe) of Windows defender service. Antimalware Service Executable is consuming high memory usage and slows down your computer, right?

You can fix by using Task Scheduler. Follow these steps and fix your problem.

  • Type “task scheduler” in the search bar and open it.
  • Click on “task scheduler library,” than Microsoft, and then select Windows.
  • Scroll down to the bottom and select “Windows Defender.” You have to click on the folder icon to open it.
  • You have select “Windows Defender Scheduled Scan” and right-click the mouse to select properties.
  • Now, select Triggers > New.
  • You have to copy the settings we have set in the snapshot we have shared below. In the snapshot, we have selected Weekly > Start Date> Start Time > Synchronise > Click OK.

Now, restart your computer, and then your computer will be back to normal.

If still not fix your problem you can see the following link to fix your issue.

https://itechcliq.com/antimalware-service-executable/

47 people found this reply helpful

Was this reply helpful?

Yes
No

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated September 17, 2021 Views 51,818 Applies to: