Why does Microsoft keep sending mails in French to my hotmail.co.uk address? !!!!

My account is @hotmail.co.uk — that's UK!!!  My selected language is ENGLISH.  It has never been French, and I've never had a hotmail.fr account.

My 'Communication Preferences' in my Microsoft profile also show "United Kingdom - English" 

But all the promotional e-mails
I'm getting from Microsoft are in FRENCH!! — and so they go straight in the trashcan.

I can only assume that this is because I sometimes connect to internet from a computer in France, and that Microsoft are linking the language of their correspondence to the IP — which is frankly stupid.  Does that mean that if I make a trip to China I'll get those mails in Chinese?!!!

Even stranger is the fact that it appears to be random.  I first had the problem for a while in 2009, then suddenly the mails reverted to English. This has happened several times since then. 

The latest mails I've had in French are from:
*** Email address is removed for privacy ***,
*** Email address is removed for privacy ***,  
*** Email address is removed for privacy ***,
*** Email address is removed for privacy ***

I've flagged the problem in the past to WindowsLive ID Support, but have had no response.  
Does anyone know whom I should contact to get these mails in  English?

I could of course block the sender, but that would mean I'd never get any communications at all.  It's not that I don't want the correspondence — I just want it in English.

It's in Microsoft's interest to sort this out, because at present all the latest information about Bing, Skydrive, Surface, etc, is going straight in the trash, instead of tempting me towards Microsoft products.




Answer
Answer

Hi,

 

Welcome to Microsoft Community. I recognized that you are receiving updates from Microsoft in a different language. It is possible that your time zone and country is incorrect. Please make sure that you have the correct setting for this option. You may refer to these steps on how to check the time zone/ country of your account.

 

1. Sign in here http://account.live.com/.

2. Click Edit personal info.

3. Under Home, click the drop down button beside Country/region then select your country.

4. Set also the region of your Country and the Time zone.

5. Click Save at the bottom of the page.

 

If you still encounter this issue, please reply to this post.

 

Thanks!

 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 
 

Question Info


Last updated September 2, 2020 Views 3,300 Applies to: