SPAM Flooding Inbox!!

Hi Microsoft, 

As you can see by all the other posts, our inboxes which are set to "safe senders only," are being breached by spammers. Can you kindly address this issue, so we do not have to see Eharmony, or Ambers private parts in our inboxes? Thanks in advance.

I have had no end of problem in getting so much spam in my inbox! I have reported this repeatedly but outlook are not taking any responsibility. It is making my life a misery. They are inappropriate messages. 

I have the spam filters, but that isnt doing the job. Please get this fixed and stop denying there is a problem on your end. All the threads relate to the same problem so we all cant be making it up. 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Heather_957,

The challenge that you're experiencing could be related to your junk filter email settings. We would like to know if you've made any changes on your email account prior to the issue. For your concern, we suggest setting your filter to Exclusive by clicking the gear icon (Settings) located at the top-right of the screen, and select Options > Filter and reporting under Junk email, then click Save.

We also recommend checking this article: Help keep spam and junk email out of your inbox in Outlook.com.

Keep us posted and we'll be willing to assist you further.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

Thanks for the response, but the problem has been resolved for a couple of weeks now.  Microsoft and I were emailing directly. 

As for your suggestions, those of us experiencing the issues, I believe most had our emails set to "Exclusive," at least I did.  Mine has always been set to that, and still is. Thanks though for the response.

Best,

Heather

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 
 

Question Info


Last updated January 19, 2020 Views 228 Applies to: