Why are my onedrive documents opening in read-only mode after installing office 365 home edition?

I'm opening a word document from my Onedrive folder on my local machine and it's opening in Word 365 in read-only mode. Why is this  and why can't I open the document in Word 2010?
 

Question Info


Last updated August 20, 2019 Views 60,704 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

My issue is opening a word document (edition does matter) and saving it on one drive.  Then when I try and save the one drive word doc, if I made changes, if won't allow me to do so unless I keep doing a save as.  This is not good or efficient.  Please fix or at least give us direction about what to do. 

Thank you

33 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hello Pastor,

 

What happens if you save and Excel or PowerPoint file?

 

Do you face the same issue if you save other Office application and edit using One Drive?

 

Are you able to edit and save the file if you save the file locally on the computer and then upload to One Drive?

 

Provide us more information to check and help you better.

 

Thank you.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I finally just reinstalled Windows 8 out of frustration with this problem. I had to have Onedrive working properly. That fixed it. The Windows 8 reinstall was a breeze. Happy as can be. I wish I knew what caused this but a reinstall worked for me.
Computer Trainer and Tech enabled

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I am having the same issues with OneDrive for Business. I have a university account. If I double click on a file in my local OneDrive folder copy, it used to open synced to both the hard drive and online storage. It's been about 4 days that when I open it, instead of the file name I get "Wd0000003.doc" (for a Word document for example). It opens in Read-only and compatibility mode even if the original file was a *.docx. I tried adding the local OneDrive folder the Trust Center trusted locations, but no luck.

Any other ideas? The only workaround is to open within Word, directly from the cloud. Very annoying.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I went in and accessed the One Drive folder from c: users/owner/one drive  

Right Clicked on the folder and added to my library.

So far, after doing this my Word Documents started opening correctly again... I hope the fix sticks!

knock on wood.

15 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I went in and accessed the One Drive folder from c: users/owner/one drive  

Right Clicked on the folder and added to my library.

So far, after doing this my Word Documents started opening correctly again... I hope the fix sticks!

knock on wood.

I think I found the problem. So far it is working!!!!

Right mouse click on One Drive and click on sync.

All docs are now opening and saving fine and no sign of read only.

One drive should sync automatically.... but for now until they come up with a fix, we probably will have to do it manually.

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

None of these fixes have helped me unfortunately.  It is literally driving me insane!  Has been four weeks so far!

If I right click on the Onedrive folder and go to Properties, "read only" is always checked.  I uncheck the "read only".  Also then do the same for the folders that I want to open within my Onedrive i.e. uncheck the read only.... and my documents are opening as read only!!  Then if I go back to see if the Onedrive folder has reset itself to read only.... yes it has.

I have uninstalled Onedrive several times now trying to fix this issue but no joy

When I am within Word on my desktop and open a file within my Onedrive folder, shouldn't that file open from my computer memory instead of "downloading from onedrive"???

Any other suggestions would be greatly appreciated.

5 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

None of these fixes have helped me unfortunately.  It is literally driving me insane!  Has been four weeks so far!

If I right click on the Onedrive folder and go to Properties, "read only" is always checked.  I uncheck the "read only".  Also then do the same for the folders that I want to open within my Onedrive i.e. uncheck the read only.... and my documents are opening as read only!!  Then if I go back to see if the Onedrive folder has reset itself to read only.... yes it has.

I have uninstalled Onedrive several times now trying to fix this issue but no joy

When I am within Word on my desktop and open a file within my Onedrive folder, shouldn't that file open from my computer memory instead of "downloading from onedrive"???

Any other suggestions would be greatly appreciated.

I found that I was having this read-only problem with only one file recently and came across this thread in my search. The things suggested here didn't appear to be the answer but it gave me the idea to compare the properties to other files that were working. This one file did not give any permissions to my OneDrive (Microsoft account) user.

From File Explorer:

Right click the file

Select Properties

Go to the Security Tab

Click Edit...

Click Add...

Type in your Microsoft account login ID

Click OK (on all 3 windows)

I've checked out nearly every other file in that folder and the one file I had issues with was the only one missing the Microsoft account.

I only did this just now, so I'm not sure if this is a long-term fix but I've since updated the file, saved it, closed it and re-opened it and it came up with full permissions.

I'm definitely interested to know if this helps solve the problem for anyone else.

8 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Adding OneDrive as trusted location makes no  difference.

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This cured the read-only issue for me when opening files in Office 2013

Open File Explorer

Right Click on the OneDrive

Select Properties

General Tab

Attributes: if there is a little black square in the Read Only Box - click on it to remove

Select Apply

Select OK

You will get a confirmation dialog that asks if you want to apply to all files & subfolders

Select OK

Another dialog will appear showing progress of updating file attributes

It will go away when complete

You Should have no more read only issues

78 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.