OneDrive on Windows 10 not syncing properly

Hello,

I've just upgraded to windows 10 today like most of the world today and I'm pretty happy with it, except that I'm having trouble syncing my onedrive folders to my machine. Whenever I go to my local ondrive folder it shows my folders like "Pictures" and "Videos" with big green checkmarks, but none of the content inside those folder is there. Onedrive says its up to date and synced, but its clearly missing the contents of most of my folders. I've looked at the support page and it recommended restarting onedrive or sigining in and out of onedrive, and neither have helped. I've also noticed that it refuses to sync new folders to my desktop if I create a folder in my browser.

Secondarily, I'm aware that onedrive in windows 10 doesn't display the names and contents of online only files like it did in windows 8.1 and I was wondering if there was a way to make it behave like that again? I really liked that.

Thanks!

Josh

 

Question Info


Last updated April 23, 2019 Views 12,221 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi,

Thank you for your interest in using Windows 10.

Your efforts to troubleshooting on this issue is very much appreciated.

I would suggest you to disconnect and re-connect your Microsoft account:

a. Press Windows key + I.

b. Click on 'Accounts'.

c. Under 'Your Accounts', click on 'sign in with a local user account instead'.

d. Follow the prompt.

Now, on the Local user account, follow the same steps to switch from Local account to Microsoft account. Now, check if OneDrive sync works correctly.

Let us know the result. If you have further queries, we will be happy to help. 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hey RajithR

I followed the steps you provided me, but it hasn't alleviated the issue. However, now when I click the onedrive icon in the action bar it says that there is 1.4MB of 1.4MB files downloading with 1 file remaining and no matter how long I leave my PC running it never finishes downloading.

Also not directly related to this specific issue, but I tried to take a screenshot to show what I was talking about using the Win+Print Screen/Win+Alt+Print Screen commands, and while the screen goes dark, I don't see the file anywhere in my photos or any other photo library on my computer.

Edit: I've solved the second issue. For some reason the admin read/write privileges were wonky in my pictures library. I'm not sure how that got messed up during the upgrade, but I can now take screenshots.

Thanks again for your time.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

Thank you for your response.

1) Does it displays any sync error?

I recommend you to check the sync problems.

To check that you have to right click on the OneDrive Icon on the Taskbar and click on View sync problems.

I also suggest you to Unlink and Relink to set up the OneDrive once again and check the issue.

  1. Right-click on the OneDrive icon in the notification area and then select Settings
  2. Select "Settings" and then select "Unlink OneDrive"
  3. Follow the setup process again and ensure to select the new drive or location to have OneDrive sync to; you must wait for your files to download again to the new location

Please reply to us with the status of the issue.

Thanks. 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

I tried the steps you listed for me once again, but they didn't do anything alleviate my problems.

However, I believe I accidently solved my problem while stumbling on to a larger issue.  Earlier, when I was unable to take a screenshot due to incorrect security permissions, it got me thinking that perhaps the same issue might be at play here. Sure enough when I checked my Ondrive folders security permissions I found that the homegroup user/ @Live.com user profile lacked proper privileges to write new files. Re-enabling privileges made the Test folder I had created on Onedrive.com show up, but not the missing files in my music and photos. I had to go in and re-enable those individually, but that immediately started the download for the rest of my missing files.

Now, my major concern is that there is a seemingly random distribution of folders on my machine without proper security permissions, even though I am the only user and Admin on this machine. I don't know what in the upgrade to Windows 10 reset my privileges, but I'm hoping there is a way to universally return them to normal?

For the record the list of effected folders I have found thus far are as follows: User\OneDrive, Onedrive\Music, Onedrive\Pictures, User\Music, User\Pictures.

I appreciate any advice on the matter.

Thanks!

Edit: My PC is actually now having a bit of a panic attack now because iCloud wants permission to download photos and updates. It keeps crashing the File Explorer and I have to open up the task manager and kill every Apple related task before I can even try to return things to normal. This issue is turning out to be more widespread than I expected.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

Thank you for your response.

There could be sync conflicts between OneDrive and iCloud. As a workaround, I suggest you to temporarily disable iCloud from the PC and check if it helps.

Also you can uninstall iCloud and check the issue status and then reinstall it from the Apple website.

Please reply for further queries on this.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

Like I said in my above post, I actually got OneDrive to download my missing files by re-enabling security privileges across specific folders that were lacking the proper permissions for no clear reason.  iCloud seemed to be suffering from the same issue, but was causing additional issues (like crashing the file explorer) because of it's in ability to write to the proper folders. At the moment I've uninstalled iCloud and I intend to try to reinstall it later tonight, however I am finding more and more folders with the same security privilege issues. What I want to figure out now is how to make sure all my folders across my desktop have the proper security privileges so I stop running into this. Thanks.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I am having the same problem you are, however I haven't found a fix.  Could you explain where you went to re-enable privileges?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hey Robby,

I'm actually really glad you asked this because I went to go take a screenshot for you and noticed that everything was back to the way it was yesterday, with the incorrect security permissions. So, you just right click on the folder and hit properties. The properties menu will pop up, click the security tab, and there you can edit what profiles have what privileges. 

I'd really like some understanding why my privileges are messed up and seem to be reverting back no matter what I do.  I'd appreciate any help with this matter.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thank you very much.  I tried looking at the permissions for OneDrive on a whole, not at the folders within OneDrive.  I made the changes and my files are actually syncing.  Thanks for the help.

Looking at the forums, it seems that many people are having problems with OneDrive.  I store quite a bit of my stuff on it, so I hope it gets fixed.  What I find strange, is that when I updated my Laptop, OneDrive was syncing just fine, even though I did the same thing on both machines I use.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Not a problem. Out of curiosity, would you check if those permissions reset when you restart the affected machine? Every time I restart my desktop those permissions reset back to read only.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.