Why does Onedrive automatically create documents folder after I delete it repeatedly?

Onedrive automatically creates a documents folder within itself about several hours to one day after I've deleted the folder.  This folder is not related to the Documents folder on the local C drive and has no files in it.  How do I stop Onedrive from automatically creating folders I don't want?
 

Question Info


Last updated October 28, 2018 Views 11,598 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi,

Thank you for contacting Microsoft Forums. 

We regret the inconvenience caused after upgrading to Windows 10.

I suggest you to change your Microsoft Account to Local Account and then change back again to Microsoft.

Type Settings on the search box present on the Taskbar, then click on Account.

On your account page, under the User name and User ID, you will be able to see "Disconnect" option.

Click on Disconnect and follow the on-line instructions.

Refer to these steps to convert Local User Account into Microsoft Account:

Type Settings on the search box present on the Taskbar, then click on Account.

Click on Connect to Microsoft Account and follow the online instructions.

Hope this helps.

10 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I did what you said and it worked.  Thank you very much. 

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I should not have celebrated too early, after 3 more days, the folder "documents" reappeared and I had to delete it again.  Also, in a separate note, The "pictures" folder now reappears though I have unchecked that box (to sync with phone pictures) several times and have deleted that folder also several times only to see it reappear.  Is there another solution?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I get this all the time, documents and pictures folder just keep coming back! So annoying!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Documents and Pictures folder wont stop creating themselves in OneDrive.

No way to make it stop.

How about letting ME decide which folders I want and what I will call them!!!???!!!

213 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

There are very annoying things that microsoft should solve easily!!! 

Its pretty annoying and incomprehensible.. I would love to have a way to penalize them seriously for this pretty stupid things.

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

We still want to know the answer... for while, I want to disturb responsibles for this little stupid ****. Very annoying!

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Same problem for Onedrive on Mac machines. The documents folder keeps getting created.

But I have no idea how to change between local and Microsoft as suggested in the forum. Can anyone provide advice on how to do that. All we have on the Mac is user preferences for the onedrive client, and there are no settings there that address this issue.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Andre,

Thank you for creating Microsoft Community.

The steps for switching the account is with reference to Windows platform. As you're using Mac, I would suggest you to perform a clean OneDrive installation and check if that helps:

  1. Unlink OneDrive by click OneDrive icon, choose Preferences, then About, click Unlink.
  2. Remove the app by following these steps:
  3. Open the Applications folder.
  4. Drag the blue OneDrive cloud to the trash.
  5. Enter your MAC credentials.
  6. Click OK.
  7. Remove the additional OneDrive files.
  8. Press Apple (COMMAND) + SHIFT+ G in finder, or use Terminal.
  9. Go to /Users/<name>/Library/Containers
  10. Find the 2 folders
    • com.microsoft.skydrive-mac
    • com.microsoft.SkyDriveLauncher
  11. Drag them to the trash.
  12. Remove the locally stored OneDrive folder.
  13. If you installed with the default settings, there will be the OneDrive folder under your name.
  14. Drag it to the trash.

Let us know if the issue still persists and we'll be glad to help you.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

The issue persists.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.