Question
13654 views

OneDrive app won't start in Windows 10

teklol asked on

I accidentally formatted the partition OneDrive was on locally, and now OneDrive won't load -- both the shortcut in File Explorer and the executable in \AppData\Local\Microsoft\OneDrive do nothing. 

As far as I can tell, there's no onedrive/skydrive related process in Task Manager, either. 

47 people had this question

Abuse history


The answered status icon Answer
Anil Madishetty replied on

Hi,

Thank you for posting in Microsoft Community.

Were you able to access OneDrive from Web?

If yes, then I recommend you to unlink OneDrive from your account and then repeat the setup process to change the location and check the issue.

  1. Right-click on the OneDrive icon in the notification area and then select Settings
  2. Select "Settings" and then select "Unlink OneDrive"
  3. Follow the setup process again and ensure to select the new drive or location to have OneDrive sync to; you must wait for your files to download again to the new location

Please note: if you've connected your Windows user account with your Microsoft account, OneDrive won't let you unlink the application. You'll have to unlink your Microsoft account from your Windows account first.

Hope it helps.

Please reply to us with the status of the issue.

Thanks.

5 people found this helpful

Abuse history


Most Helpful Reply
Pirwen replied on

Hello! I stumbled upon this thread on my first day of researching this issue. I spend a bit over 4 days trying everything I found here and on the web, and like you everything failed. I finally got it working again without reinstalling Windows (I'm on a surface pro 3, so it's a pain as there's not recovery partition), so I wanted to leave it here in case it is useful to anybody.

I remembered seeing an option to prevent the usage of OneDrive via the Group Policy editor, seems that there is also an option to force enable it. Here are the steps I followed:

  • On your keyboard hit Windows Key + R to open the Run dialog and type: gpedit.msc and hit Enter to open Local Group Policy Editor.
  • Next navigate to Computer Configuration\Administrative Templates\Windows Components\OneDrive. In the right panel, double click Prevent the usage of OneDrive for File Storage.
  • Then here instead of selecting Enabled (as many tutorials suggest to disable OneDrive on Windows 10) I selected Disabled, and saved my changes. This option was originally unset, which should have worked just as if it was disabled, except it didn't.

After doing this I opened OneDrive again and got a notification for an update. After a few seconds it opened, and was finally working again.

Hoping this works as a permanent solution, or while they pinpoint the issue.

95 people found this helpful

Abuse history


progress