OneDrive error "Cookies must be allowed" on Windows 10

Hi those @ Microsoft community,

I just upgraded my PC to Windows 10, and everything went smoothly (thanks Microsoft!) apart from when I tried to set up OneDrive. I get a notification asking me to sign in to OneDrive, and the OneDrive window pops up. I click the "Get Started" button, and after that the window goes blank for a while and then displays an error message:

  

I have gone through every browser (Edge, Internet Explorer, Firefox and Chrome) and enabled all cookies and tried again, but to no avail.

Is there any fix for this?

Thanks

David

Answer
Answer
All you have to do is go to the search bar and type in cookies. You should see an option to "block or allow third party cookies" on control panel. Click on that and you will be taken to "Internet Properties". You should be under privacy. Under settings on that page, click "Advanced" and on third party cookies, the box Block should be ticked. If this is so, click on "Accept" and then go restart the Onedrive app and it should take you to the sign in page. I hope I have been helpful.

37 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer
Answer

I had this problem for a long time but although it said I needed to enable cookies (all of which were enabled in every browser) it still worked fine if I just closed the warning window. Last week that changed and it wouldn't even log in because it wanted me to enable cookies.

After about 3 hours with Microsoft on the phone the problem was traced to an issue with IE 11. Onedrive uses IE 11 to effect its login, and it is in that which cookies need to be enabled. Just as many people here have found, my IE 11 claimed to have cookies enabled.

I did some research for registry entries that might be related to accepting cookies and found that HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\3\1A10

should be set to 0. Mine was set to 5f1. I changed it and it now works fine.

Good luck.

113 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 
 

Question Info


Last updated November 27, 2019 Views 16,924 Applies to: