OneDrive Seems To Be Locking Folders As Read Only

I recently subscribed to MS Office and with the expanded OneDrive space, I set up My Documents to synch automatically to OneDrive. All worked well until a few days ago. I started having problems download files from SD cards. I checked and My Documents and all subfolders are marked as Read Only. I uncheck the box, but all folders immediately revert back to Read Only. I think this is related to my OneDrive and I cannot seem to "unlink" My Documents with OneDrive.

Any suggestions?

Thanks!

 

Question Info


Last updated April 30, 2018 Views 2,291 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi,

Thank you for posting in Microsoft Community.

1) Did you set up My documents folder under OneDrive folder in File Explorer?

2) Are you trying to Unlink only My Documents / OneDrive from Computer?

3) Which Operating System you have on a Computer?

By default the folders and files in the My Documents will be in Read only mode. So you have to change manually if you don't want a folder/files to be read only mode.

When you setup a folder/file to be synced to OneDrive it should be under OneDrive folder in File Explorer.

Please reply to us with the more information.

Thanks.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Anil,

1) Yes, I did set up My Documents folder OneDrive folder in File Explorer

2) I am try to unlink ALL folder including My Documents, but especially My Pictures*

3) I am running Win 10 Tech Preview Build 10162

I manually change from Read Only, but the folder immediately revert back to Read Only.

Your help is appreciated.

Thanks!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

First upgrade to the latest build 10240 and check if you are still not able to change to read only.

If the issue persists switch the Microsoft account to a Local account, then switch back to Microsoft account. Try to set up OneDrive again and check if the issue persists. 

Keep us informed on the status of the issue. 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Anish,

I successfully upgraded to Build 10240.

What do you mean by "switch the Microsoft account to a local account"?

Thanks!

Bill

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Converting Microsoft account into Local user account then Local user account into Microsoft account might help you in fixing the issue.

Refer to these steps to convert Microsoft account into Local User account:

  1. Click on Windows button, then click on Settings.

  2. Click on Accounts then click on Your account.

  3. Click on Sign in with a local account instead.

  4. Following the Online instructions.

Refer to these steps to convert Local User account into Microsoft account:

  1. Click on Windows button, then click on Settings.

  2. Click on Accounts then click on Your account.

  3. Click on Connect My Microsoft Account.

  4. Following the Online instructions.

Hope this information helps you.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Ganesh,

Unfortunately, all folders immediately revert back to read only. Error messages in both Adobe Photoshop and Adobe Lightroom point to OneDrive.

I had set OneDrive to automatically back up My Documents (and My Pictures.) What is the simplest way to just delete OneDrive?

Thanks!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

Thank you for your response.

The actual read-only flag on a folder is used by Windows to mark that the folder has special customizations, but doesn't restrict write access to the folder or its contents. When you look at a folder's properties, the read-only box will always show the half-way gray state. This means "don't make any changes to read-only flag on the files in this folder". You can check (or clear) the box to mean "make all the files in this folder read-only (or read/write)."

As a workaround, I suggest you to modify the read-only flag for a folder using the command on any one of the folders.

To remove the Read-only attribute and to set the System attribute, use the following command:

attrib -r +s drive:\<path>\<foldername>

For example, to remove the Read-only attribute and to set the System attribute for the C:\OneDrive\Test folder, use the following command:

attrib -r +s c:\OneDrive\test

Note: Be aware that some programs may not operate correctly with folders for which the System attribute and the Read-only attribute are set. Therefore, use the following command to remove these attributes:

attrib -r -s c:\OneDrive\test

Hope this helps.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Arvind,

The Read Only attribute box is not greyed out, it is "black" the same as it if selected. Running your suggestions at the command prompt, regrettably, has no effect. The folders remain read-only.

Thanks for the suggestion though.

Anyway to simply disable OneDrive. My computers sure ran better without this cloud nightmare.

Thanks!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

Sorry for the inconvenience caused to you.

We have reproduced the issue and seems that it is a bug. We have escalated this issue. we will get back to you with more information. In the mean time could you please let us know the exact issue now you are facing and if you are using Windows 8.1 then there is no way to disable OneDrive from computer.

Thanks.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hello Anil,

I had the exact same problem and have just upgraded to Windows 10.

There's a permissions issue. The read-only attribute is in fact marked black, but it does in fact look like it isn't connected with the underlying permissions.

ArchtopBill, here's what I suggest you do:

1. Right click on the OneDrive Documents folder and select Properties

2. Click the Security tab

3. Highlight any of the Group or user names and click the Advanced button on the bottom

4. Make sure that SYSTEM has Full control access.

I've personally set it to inherit all permissions from C:\Users\Admin and have inheritance enabled.

5. Mark the Replace all child permission entries with inheritable permission entries from this object checkbox

6. Click Apply

All Documents subfolders and files will inherit the Full control permissions.

This should solve the problem. If not, make sure your user also has proper permissions set. Let me know if you have any questions.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.