OneDrive icon missing from system tray

new surface book pro/windows 10. found the directions once and added it now missing again and I can't find the directions to add to system tray. Went to select icons in settings and onedrive is not in the list... (also, can't get screen shot to work using onedrive????)

Moved from: OneDrive / OneDrive in Windows 10

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi,

To show the icon for OneDrive on your system tray, you'll have to go to the Taskbar and Navigation area in Control Panel. To do that, you can follow the steps below:

  1. Press Windows+X key on your keyboard, then select Control Panel.
  2. Select Taskbar and Navigation.
  3. Click Select which icons appear on the taskbar under the Notification area section.
  4. Scroll down and turn on the option for Microsoft OneDrive.

Update us if it addressed your issue.

Thank you.

7 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

1. Win-X menu did not contain Control Panel. 

2. Searched via Cortana & found Taskbar & Navigation 

3. Found Notification Area section and Select Which Icons sections

4. Select Which Icons did not contain OneDrive as a choice.

I've been using OneDrive since I got this Surface Pro a couple of years ago and it still appears fine from File Explorer, but Surface has quit syncing with the cloud and new stuff is not visible from other devices.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hello Bill,

If your OneDrive icon is also missing in the notification area and have tried the steps above to no avail. We would like to know which Windows 10 version and build is installed on your device? Does the OneDrive icon appear on the notification area when you open OneDrive?

In the meantime, if you have issues with syncing your OneDrive to your other devices you can refer to this support article: Fix OneDrive sync issues. This article contains steps that you can perform to help you address your query.

Looking forward to your response.

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Well, not really helped by the reply, but ultimately by the forum, despite its convoluted, guess-based self-contradicting advice.  What's good about the reply is that it gives me a chance to tell you what happened.

I spent a couple hours trying several of the "solutions" offered to "loss of OneDrive icon" (running exes from cmdline etc).  I put several others on the back burner as too complicated to risk all the effort without first trying simpler ones (e.g., "spawn a new user identity" etc).  Then I finally hit a guy who said (paraphrased), "Hey, I just started the OneDrive App from the start menu instead of going there from a browser, and my OneDrive Icon reappeared on the task bar and sync started to work!"

So after hours of reading and trying things, I started the OneDrive App and voila!   Icon back, sync working.

No idea whether my previous attempts were necessary but they certainly weren't sufficient.

Suggest you include, early and often, the suggestion to try starting OneDrive with the App interface vs browser interface for this problem.  It doesn't cost three hours or even three minutes, and for me, it worked.

Also suggest you diagnose the action the App is taking that is absent from the browser and file-explorer versions.  It looks just like File Explorer but is apparently doing something differently.

My old habits of using File Explorer (generally) and Edge or Chrome (rarely) to interface with OneDrive are now working fine and do not "unfix" the problem.  But if it ever recurs, I hope I remember to go hunt around on the Start menu, find the app, and fire it up.

Thanks

Bill Tolson

Using W10  v1703 bld15063.540

55 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Addendum/PS to previous post: 

Once I got the icon back, and was able to get to OneDrive Settings, I noticed that the general settings boxes

- Start OneDrive Automatically when I sign into Windows

- Let me use OneDrive to fetch any of my files on this PC

were both unchecked.

I turned on the Start Automatically, thinking it should be on.  Maybe that's what was making the icon fail to appear on bootup.  Don't know how it got Unchecked.  Not by me.  Anyway, perhaps browsers & File Explorer do not or cannot check for the process and start it if it's not running.

Just now I also turned on Fetch.  I at least want to try it.  If I understand it correctly, it will allow me to copy files from my hard drive to another person's.  Didn't know about this so I may have learned something useful from all this, and for that I thank you.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi, I had the same problem.

What worked for me was the following:

open 'regedit' by holding windows key and r at the same time and typing 'regedit' then enter

look for the key:

Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Onedrive

and make sure the following key: DisableFileSyncNGSC is set to "0"

It may be set to "1" when you find it.

Restart the computer

Manually start OneDrive by clicking the icon (the 'blue cloud in the folder') from the start menu.

Be sure to change the options if you want onedrive starting up every time you start your pc.

11 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Well, I've been opening it from the app and the icon doesn't appear in the notifications when the app is open right there in front of me. Since this appears to be the only way to get to the settings, it's a bit useless. On another computer I have it starts when the computer starts, so if I restart that one, the OneDrive icon appears. This computer obviously doesn't have that checked, and there's no way I can find to get to the settings.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Try this. It worked for me. 

Use Cortana and type OneDr. Result should show on the Best Match, OneDrive Desktop App. Icon is a Folder with the OneDrive logo. Then it will open the OneDrive folder and voila! the OneDrive icon should appear in your taskbar.


Once the icon appeared on your system tray, right click the icon and go to Settings, tick the Start OneDrive when I sign in to Windows.


System

Windows 10 Pro

Version 1709

OS Build 16299.192

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Try this. It worked for me. 

Use Cortana and type OneDr. Result should show on the Best Match, OneDrive Desktop App. Icon is a Folder with the OneDrive logo. Then it will open the OneDrive folder and voila! the OneDrive icon should appear in your taskbar.


Once the icon appeared on your system tray, right click the icon and go to Settingstick the Start OneDrive when I sign in to Windows.


System

Windows 10 Pro

Version 1709

OS Build 16299.192

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I tried this, but unfortunately OneDrive did not show up.  I also checked the "Select which icons appear on the taskbar" and Microsoft OneDrive is not listed.  I have uninstalled and reinstalled OneDrive but nothing has worked.  We previously disabled OneDrive via GPO, but are using a test GPO and turning it back on with a test computer.  I have verified that the registry key is showing that it is enabled.  Any other suggestion get the OneDrive icon to show in the system tray or just plain get it to work.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Question Info


Last updated July 20, 2018 Views 9,282 Applies to: