How can I make Word 2013 open in Draft View by default?

I use Word 2013 on a 14" laptop and the default view, Print Layout, is a colossal waste of space, but I can't get the program to open in Draft View by default. Have done the following:
  • Changed settings to "allow documents to open in Draft View"
  • Saved documents in Draft View...they re-open in Print Layout
  • Tried to change New Document template to Draft View but new documents still only open in Print Layout.

I hope that the answer is not "you have to change to draft view every single time you open a document." There are already a lot more clicks / action in Word 2013 than in previous versions.


Have searched forums but there doesn't seem to be an answer for this in Word 2013.

Thanks for your assistance.

BP211
 

Question Info


Last updated December 30, 2019 Views 43,073 Applies to:
Answer
Answer
Follow the instructions at http://www.gmayor.com/installing_macro.htm to put the following two macros into a module in the Normal.dotm template:

Sub AutoOpen()
    ActiveWindow.View.Draft = True
End Sub

Sub AutoNew()
    ActiveWindow.View.Draft = True
End Sub

The first will run automatically every time you open an existing document, and the second will run when you create a new document.
_____________________________
https://jay-freedman.info

11 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer
Answer
That one's hidden about as deeply as possible. A lot of the things in the Options dialog are properties of the Options object in VBA, so you can say things like Options.Overtype = False. Controlling the draft font display is not one of those things. :-(

Actually, it's a throwback to Word 2003 and earlier. The Dialogs collection includes a member called Dialogs(wdDialogToolsOptionsView), which refers to a tab of the Options dialog that no longer exists (and of course the Options command isn't on the Tools menu, which doesn't exist). That dialog has an argument named DraftFont, which is a boolean (true/false) value. So this is how you do it:

Sub AutoOpen()
Dim dlg As Dialog
Set dlg = Dialogs(wdDialogToolsOptionsView)
With dlg
    .DraftFont = False
    .Execute
End With
ActiveWindow.View.Draft = True
End Sub

and similarly for AutoNew().

By the way, both your original problem and this one point the the probability that there's something amiss in your Windows registry, because these things should be saved there automatically. This trouble sometimes happens when you have certain third-party add-ins or other programs that interfere with Word's ability to write to the registry. There can also be misconfiguration of the permissions for certain parts of the registry. If you think that working with macros is harrowing, you don't want to know how to troubleshoot the registry. If these two macros solve the problem, leave well enough alone.
_____________________________
https://jay-freedman.info

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.