EXCEL slow loading in Windows 10

After upgrading to Windows 10 on my Surface Pro 3,  I have Office 365 installed.  If I click on an Excel file it takes 8-10 seconds before the Excel banner even appears.  It doesn't matter how small the Excel file is, I get the same results.  Word loads normally, even with large files.  Anyone else experiencing this?

Humm, just noticed another anomaly.  If I first open Excel it opens instantly.  If I then select the Excel file in Recent files it will load instantly also.  So the slow loading only occurs if I double click the Excel file directly.  Strange...

UPDATE:  Answer found!!  It happens when you have Hey Cortana turned on.  Turn Hey Cortana off, reboot and Excel files will load normal.  Very fast.   Surprised MS hasn't seen this and fixed it.  Found the answer on the internet.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

I find that this issue is most apparent when trying to open an excel file attachment on an outlook email. It takes so long to load, I try re-opening it and end up with the same file open half a dozen times..

5 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

1. You may login to Windows with a new user profile and see if it helps.

2. Review the following thread - http://answers.microsoft.com/en-us/office/forum/office_2013_release-excel/cannot-open-some-office-files-after-upgrading-from/c103ee49-2e87-4421-ad96-f433ec77ec54

3. Zorvek (http://answers.microsoft.com/en-us/office/forum/office_2013_release-excel/windows-10-and-microsoft-excel-2013/f886877d-b486-4d57-bd61-73e30b7ded81) has given following solution which you can try -
Windows 10 is causing some issues with Office/Excel. Some of the issues are resolved by disabling a new function of the .net installation that comes with Windows 10 and Visual Studio 2015. This feature can be disabled with a registry entry.
To create the entry, run PowerShell with administrator privileges (open the Start menu, enter PowerShell in find box, right-click on PowerShell and select ""Run as administrator"". Enter the following command to add the registry entry:
Set-ItemProperty -Path HKLM:\Software\Microsoft\.NETFramework -Name useLegacyJit -Type DWord -Value 1
You can copy the above line and paste it into PowerShell by clicking on the top left part of the PowerShell window title bar and selecting Edit->Paste. Press ENTER to run the command.

4. Read the response of Try*3  (http://answers.microsoft.com/en-us/office/forum/office_2007-excel/windows-10-excel-files-changed-to-read-only/cba3c358-21b5-472d-b5e2-f690f1b0a49b). He has provided a link which also has solutions for problems.

5. If above don't, re-installation of office may solve your problem. Make sure that you have license keys ready before you attempt re-installation.
Best regards
Vijay Verma

Timezone: UTC+05:30, PST+12:30
Availability Hours (UTC) : 05:00 AM - 05:00 PM

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I tried your recommendations, but the only thing that really happened is it uninstalled Office 365 and reinstall it.  It changed nothing.  The only problem I have is when I click an Excel file directly it takes about 10 seconds to load.  If I first open Excel and then open the file it loads instantly.  Word has not problems, it loads files instantly.   I'm using a Surface Pro 3.

Bwalls

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I access two Excel files (very tiny) through a OneNote notebook and they open incredibly slowly!  On several occasions, OneNote has crashed and restarted when I open one of these files.

You've posted that reinstalling Office 365 had no effect, so I'll skip that.  Thanks

Surface Pro 3 upgraded to Windows 10

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have the same experience with my Dell XPS 13 using windows 10 and Office 2010.  Takes at least 10 seconds to open an excel file directly unless an instance of excel is already opened.  It doesn't matter the size of the excel file.

Does anyone have any solutions for excel files opening slowly with windows 10?

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Two additional pointers -

1. Right click on your Excel shortcut > Properties, In Compatibility tab, uncheck all options. Start the Excel again.

2. Right click on your Excel shortcut > Right Click on this, Properties, In Compatibility tab, check "Run this Program as an Administrator"
Start the Excel. You might again get the error. Close Excel and uncheck "Run this Program as an Administrator"and start Excel again.

Best regards
Vijay Verma

Timezone: UTC+05:30, PST+12:30
Availability Hours (UTC) : 05:00 AM - 05:00 PM

27 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Vijay,

I noticed on the internet a number of users have identified the problem with having Hey Cortana turned on is messing up the Excel load times.  I turned off Hey Cortana and Excel loads normally.  There is a glitch in Hey Cortana that is problem with the slow Excel load times.  MS needs to be aware of this and get a fix in the works.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I turned off Hey Cortana and rebooted, but it did not solve my problem.  I also ran a 'repair' on Office 2013 Pro and it did not have any effect.  When you start Excel directly, it comes up with no delay.  If you double-click on an Excel file, the delay is annoyingly long.  Running Windows 10, completely up to current cumulative patch levels.  Hopefully this will be solved soon.

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Try this also -

Follow the instructions given on this page to make older programs compatible with Windows 10 - http://windows.microsoft.com/en-IN/windows-8/older-programs-compatible-version-windows 

Best regards
Vijay Verma

Timezone: UTC+05:30, PST+12:30
Availability Hours (UTC) : 05:00 AM - 05:00 PM

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Vijay,  Thanks for your suggestion.  I tried the program compatibility troubleshooter and it changed my settings to Windows 7 (for Excel).  This caused an additional problem where the excel file would not load, so then it suggested Windows 8.  It corrected the file load problem, but not the slow start problem.

New information, when starting from START screen, Excel takes less than a second to start.  When double-clicking an excel file it takes 12.8 seconds to start.

Thanks for any additional tips to try.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Question Info


Last updated October 19, 2020 Views 33,476 Applies to: