Word 2013 hyperlink converting # to %20-%20

The following is the URL for a hyperlink in a Word doc.  Please note the "#" near the end.  When reading the doc in Word 2010 the link works great.
http://windows.microsoft.com/en-us/windows7/help/videos/windows-xp-vs-windows-7#tab=compare

But if I open the doc in Word 2013, what gets put in the URL bar of the browser is:  
http://windows.microsoft.com/en-us/windows7/help/videos/windows-xp-vs-windows-7%20-%20tab=compare

This doesn't work, and I have to go in the browser address bar and edit the # back where it's supposed to be.
(I've since figured out that I don't really need the # and everything after, but I might one day.)

This problem exists when the default browser is set to anything other than IE-desktop.
IE-W8 = problem (# converts to %20-%20)
Chrome = problem (# converts to %20-%20)
IE-desktop = NO problem (# stays #)

I'd like to use the IE W8 browser.

Any help is greatly appreciated.


* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi Carlton,

 

I would like to know more details before we proceed with the troubleshooting:

What is the format of the Word document?

Are Word 2010 and Word 2013 installed on the same computer or different computers?

 

Since the issue occurs when the default browser is set to a different one apart from IE.

You may repair the Office 2013 suite following the steps from the link below and check if the issue occurs:

http://support.microsoft.com/kb/2769349

 

Let us know the details and hope the suggestions provided are helpful. If you need further assistance, reply and I will be happy to assist you.

Thank you

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thank you for your reply.  I'm not sure I understand the question about format.  The saved Word doc is a .docx, but the problem occurs regardless of whether I open a previously saved document or if I just open Word and start typing. 


Word 2013 and 2010 are not on the same computer.


I ran the office repair and it makes no difference.


I've tried this on three W8 computers with Word 2013.  If IE-W8 is set as the default browser the problem exists.  If Chrome is set as the default browser the problem exists.  If IE-desktop is set as the default browser, no problem.


I just verified that the problem is not limited to Word 2013.  The same behavior occurs whether the link is in Word 2013 or PPT 2013 or Excel 2013.


Thank you.




Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

What do you mean by IE W8 and IE Desktop?
Hope this helps,
Doug Robbins - MVP Office Apps & Services (Word)
dougrobbinsmvp@gmail.com
Screen shots by Snagit from www.techsmith.com

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Doug.


IE W8 means the IE on the Start screen.  IE Desktop means the IE on the desktop.


I don't know if they're two different displays of the same thing or if they're actually different things.


In Control Panel I can change http and https to IE or to Chrome.  If I set to IE, then within IE/Internet Options I can change the default to either IE or IE (desktop).

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I am having the same issue of # in a Word hyperlink converting to %20-%20 when opening in the browser. It happens with the following combinations:

  • Word 2010 and Chrome
  • Word 2013 and Chrome
  • Word 2013 and IE 10

When the hyperlink is pasted into a browser window directly, the # stays intact and opens in the browser as # (the link works).  

When the Word document is converted into Adobe Acrobat, the hyperlink is retained as # and when clicked to open, the # stays intact and opens in the browser as # (the link works).

Our final product is a set of Adobe Acrobat files that link to each other via named destinations, which allow the user to open to a particular heading (page) in the PDF based on the named destination (that is indicated with #destination).  However, we also post the Word documents and right now all the links in Word are not working.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

 

Let me assist you with the issue.

Before we proceed with the troubleshooting steps, I need more information:

Is Office 2010 and Office 2013 suites installed on the same computer?

What is the format of the file (.doc or .docx) that you are trying to open on Word 2013?

 

Create a new Word document, save it as Hyperlink and check if the issue occurs.

 

Let us know the details and results for further assistance.

Thank you.

Note: It is always advised to create your own thread, so your issue will be addressed best and with priority.


Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Aravinda,

I have Office 2010 and Office 2013 on the same computer; in addition, I have another computer with Office 2013 only. I have tried all computers and all combinations with either .doc or .docx and get the same result.  I have found this Knowledge Base article from Microsoft indicating that this is a known issue: 

http://support.microsoft.com/kb/202261.  However various forums indicate that this is a recent issue that was introduced, which has been similar to my experience.  I was able to use # in hyperlinks (Word 2010 & Word 2013 with either .doc or .docx) approximately 6 months ago and now I cannot.  Any idea when Microsoft will fix this bug?  # is necessary for named destinations in Adobe PDF, so the hyperlinks are valid links.

Thanks

Jennifer

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This behaviour is inconsistent across similar set-ups. All of us have Word 2010 and IE 10 but only a few experience the issue.  Extremely frustrating, and it's impeding our ability to conduct business.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I've got the same Problem with Office 2007

Fresh installation on new Computer with Windows 7

For some people opening the same document. Links with '#' work

for other people it doesn't work

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

Try to change default value (htmlfile) of HKEY_CLASSES_ROOT\.htm key by another value.

by example :

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\.htm]
@="IEhtml"

I had the same problem on Windows 7 with Office 2007 SP3 when update from IE8 to IE11.

49 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Question Info


Last updated May 25, 2020 Views 29,796 Applies to: