How do I get Visio to stop automatic resizing permanently?

HELP! I have been using Visio in various versions since 2000. I made a template with a specified single page size (8.5x11). The template includes multiple backgrounds and sheets for use on projects. All pages are a single size. When I save the drawing from the template everything is fine, the page sizes are still set to the values I configured. When I drop objects onto the page from other drawings for use, or duplicate the page, or edit objects not within the page size I set, the page automatically resizes.

How do I get Visio to use a single predetermined page period, No resizing At All, Ever?
 

Question Info


Last updated June 10, 2019 Views 1,634 Applies to:

Hi,

You can disable the auto size in Design Tab.

Move to DESIGN --> Page Setup --> Auto Size (Click on Auto Size to disable)

 

Let me know if you meant something else.

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Dheerajbahal, I did mean something else. The Auto Size feature turns on automatically, I don't want to have to disable it for every page every time I create a new document.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Cjinns,

There is no out of the box way to disable it permanently however you can write your own custom add-in for this.

Follow this link for reference

http://msdn.microsoft.com/en-us/library/gg577628(v=office.14).aspx

Thanks,

Dheeraj

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks Dheeraj,

When I follow the link it appears to me that the solution you've indicated is how to add Auto Size for Vision 2010. I've looked at the Page.AutoSize property, Page.AutoSizeDrawing method, and Document.DiagramServicesEnabled properties.

When I checked DiagramServicesEnabled property it is set for 0, which should mean that visServiceAutoSizePage is disabled, yet the menu button is still "On" by default when creating a new page.

I tried the VBA code and substituted False for the True:

Public Sub EnablePageAutoSize()

    ActivePage.AutoSize = False
    ActivePage.AutoSizeDrawing
        
End Sub

After saving as a Visio Macro-Enabled Template (*.vstm) I closed and reopened the file, several times to make sure the template was exactly as needed. Opening a new drawing from the template everything appears to be working as desired for bot 2013 and 2010 versions.

Thank you for your help,

Chris

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Chris, Do you have to apply this solution to every file?  Have you tried applying to templates so all new files inherit the (in theory) default value of False?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

The Visio Macro-Enabled Template (*.vstm) file does contain the VBA code and has been working for all new documents created from that template, so that is the solution.

Chris

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.