Making desktop onenote default for windows 10

Hello

So I've just received my windows 10 pro today

I tried making my onenote desktop as my default but when i bring up the menu from the right side and click "note", it still brings up the none desktop version of onenote

how do i fix this?

thank you

(i have SP3)

 

Question Info


Last updated May 2, 2019 Views 25,291 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

I've found a way to hijack the notifications panel Note button, without having to uninstall the default onenote modern app.

• First create a reg file with this content (modify path to onenote.exe if needed) :

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\OneNote-sidenote]
@="URL:onenote-sidenote Protocol"
"URL Protocol"=""

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\OneNote-sidenote\shell]

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\OneNote-sidenote\shell\Open]

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\OneNote-sidenote\shell\Open\command]
@="\"C:\\Program Files\\Microsoft Office 15\\Root\\Office15\\ONENOTE.EXE\" /sidenote /paste /nologo"

• Open regsitry editor and go to this key:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\ActionCenter\Quick Actions\All\SystemSettings_Launcher_QuickNote

• Change contents "Uri" to this: "onenote-sidenote://"

• Now restart Windows Explorer via task manager (ctrl+shift+escape).

• If all goes well, tapping that "Note" tile will now open a Onenote dekstop sidenote with  current clipboard contents pasted in.

• This is backwards-compatible with at least OneNote 2007.

edit: fixed a typo.

Thx for your fix, but it doesn't work on x64.

Do I need "(x86)" at path for "Program Files"!?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Correction: It worked temporarily but the OneNote app then miraculously reinstalled itself :(

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Yeah, make sure the path to OneNote is correct.

Run Onenote desktop, then open Task manager. Find onenote.exe there, right click > properties, and see what's it's location (and filename) is.

Also, see, the reg file you create, that has to be merged with the registry. (forgot to type out this step)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi

This works for me

Step 1 - Setting default program

1 - Open Control Panel

2 - On View By click on small Icons option

3 - Click on Default Programs icon

4 - Click on Set your default programs icon (Waiting for loading message)

5 -  On list (left side), select OneNote (desktop)

6 - Click on Choose defaults for this program link

7 - Click on checkbox Select All

8 - Click on Save button

Step 2 - Checking default program

1 - Open OneNote (desktop) program

2 - If it isn'showing the message "OneNote is not your default...." - It works !

3 - Click on File menu

4 - Click on Options menu

5 - Click on Advanced options (left side)

6 - Scroll the bar until Default OneNote Application

7 - If the option is selected, it works ! you won't see the message again.

By Condé

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Use "C:\PROGRA~2\MICROS~1\Office15\ONENOTE.EXE" (or use the path from your own registry key [HKEY_CLASSES_ROOT\onenote-cmd\shell\open\command] - without the /hyperlink "%1" parameters)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

OK, finally successful! :-))))

Using Windows10 Enterprise x64 and Office 2013 x86 and following - reg File:

-----------------------------------------------------------------------------------------

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\onenote-cmd]
 @="URL:onenote-cmd"
 "URL Protocol"=""

[HKEY_CLASSES_ROOT\onenote-cmd\Shell]

[HKEY_CLASSES_ROOT\onenote-cmd\Shell\Open]

[HKEY_CLASSES_ROOT\onenote-cmd\Shell\Open\Command]
@="\"C:\\PROGRA~2\\MICROS~1\\Office15\\ONENOTE.EXE\""

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I found this on the Microsoft  Surface support site:

https://www.microsoft.com/surface/en-us/support/touch-mouse-and-search/surface-pen-default-onenote?os=windows-10

Essentially it says that Microsoft knows about the pen-click always opening the metro version, and that they will eventually fix it.

Too bad someone from Microsoft couldn't have given this statement within this conversation.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Well, that certainly answers the question. Thanks for the information.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have the same problem.  I am very well accustomed to the Pen Button launching the Desktop version of One Note. I see there is a button now on the right - action center, where the charms used to be - to launch One Note. Which it launches a rather meager One note which comes with the Win10.


I would like to have the option back to (And not only to have the option but to have the option to WORK as well.) to launch One Note Desktop from the Pen for SP3 and the Action Center Button as well.

Sp3 User here.

Please Help.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Great!  Thank you!  I had to modify code for the new location where MS Office 15 installs.

For those who don't know how to use this code, create a new plain text document using notepad, then paste the code given below into the file and save the file with the extension ".reg":

----------------------------------------------------------------------------

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\onenote-cmd]
 @="URL:onenote-cmd"
 "URL Protocol"=""

[HKEY_CLASSES_ROOT\onenote-cmd\Shell]

[HKEY_CLASSES_ROOT\onenote-cmd\Shell\Open]

[HKEY_CLASSES_ROOT\onenote-cmd\Shell\Open\Command]
@="\"C:\\Program Files\\Microsoft Office 15\\root\\office15\\ONENOTE.EXE\""

--------------------------------------------------------------------------

After pasting that code and saving as a .reg file, double click on the file to execute it.

HOWEVER, backup your registry before running.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.