visio select default printer

Hello all.

Some time ago I faced with little but not very pleasant MS Visio 2010 feature - Visio 2010 does not upload paper standards from currently active and selected printer.
I have few printers on my system, one is regular laser printer and another one is plotter. I need printout work from Visio on plotter, but much more often I work with regular printer. When I select my plotter at system printer in Visio 2007 on WinXP (there are separate listbox on PrintPreview's menu bar) and then go to Page Setup, I have paper sizes there available for currently active printer (in my case I have paper sizes for plotter A1 and etc...). When I did the same in Visio 2010 on Win7 - Select my plotter in listbox (which I previously put to roll), and then go to Page Setup, I have only paper sized for my system's default printer, not one I selected in Visio. I have no ability to select A1 paper size in Visio, because my system default laser printer is not support one. How I can solve this? Now I have solution to print out my Visio works to PDF and then print out PDF to my plotter, but it is not very good, because there are problems with formatting. If I will not find any solution for this, I will roll back to 2007 again :(

Thanks in advance.

P.S. I have few screenshots, what i'm talking about, but I was unable to attach its here.

 
 

Question Info


Last updated June 3, 2019 Views 1,908 Applies to:
Visio 2010 should be able to get the printer information if the printer is set as Default before launching the application.  Try setting the plotter as default, and configuring it's setup before you launch Visio, and see if that helps.  There are some printers that don't provide Visio the right information when you are in the Print Setup mode, so it's best to try this as your work around.
Please remember to click “Mark as Answer” if this response helps you.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This is a bug in Visio (IMHO). Visio can only get the page size from the default printer. You can't set a printer without actually printing.

So if you want to set up your page to a plotter size (such as A1 or A2 for example) you have to temporarily change your default printer to the plotter.

I have never seen this behaviour in any other similar application.

Let's hope this can be fixed in newer versions of Visio!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.