Interpretation of key of numeric keypad as decimal separator

The problem I have occurs when using an AZERTY keyboard (BE, in my case, but it's the same with FR layout)

It's important to know that, on AZERTY keyboards, a full stop ('.') is typed using the SHIFT key on the semicolon key (';'). That requires two fingers...
It is the same for digits.
But, on the numeric keypad, there is no shift for digits and there is a key with a  full stop ('.'), also without SHIFT (the same as the "Del" key).
Therefore, many people often use the numeric keypad for digits and full stop, instead of a SHIFT combination on the standard part of the keyboard.

For the full stop, this works for all applications except two: Excel and PowerPoint.

Why ? Because these two applications consider that the full stop key of the numeric keypad is the decimal separator.
Therefore, they do not use the keyboard layout for that key, but they use the character defined in the Windows local settings for the decimal separator.
Consequence: when the decimal separator in local settings is the comma (','), typing on the full stop ('.') key of the numeric keypad results into a comma (','), although this is not what's drawn on the keyboard :-(

Last but not least: there are three options for the keyboard layout: Belgian-comma, Belgian-period, and Belgian-French (default one, which is like period). They change the behavior of the numeric keypad (you can choose between comma and full stop for the numerical keyboard). It works in all applications except, of course, Excel and PowerPoint!

In Excel, when entering a number, this can be, more or less, acceptable: it allows entering decimal numbers using the numerical keyboard only. That's a common use case in Excel.
But, this behavior has been introduced in PowerPoint too, although PowerPoint is not an application dedicated to numbers. This is very annoying and actually perceived as a bug.

I (and many others) tried to find how to change this but didn't succeed:
- Changing the locale setting for numbers is not acceptable. Indeed, the comma (',') must remain the decimal separator when displaying numbers in applications (including Excel).
- There is no dedicated option in Excel nor in PowerPoint.
- I didn't found any article in Google, except some who state that the locale setting is wrong (that's a wrong answer - but the problem is specific too few language/keyboard combination, so that, except in a few countries, people are not aware of this strange behavior).

Who has a solution to change this in PowerPoint?
James
 

Question Info


Last updated September 20, 2018 Views 15,098 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Buy a USB key board for each language if you are shifting so many languages.. change the keyboard when required

 

BLACK BARRON


P.S : Please post back with the status of the issue. If this post was helpful to you, please vote for my post If this post has helped you resolve your issue, please mark my post as answered.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Unfortunately, your answer does not help.

First of all, I do not switch "so many" languages. I use only two: French and English.

I use an English version of Windows at office and French at home, but this is not the cause problem because Excel behaviour is identical in both cases.

The keyboard layout is always the same and I type very fast with it, there is no reason for changing. And, with an English (QWERTY) layout, I will loose the ability to type all accents, like éèçàùëêüûïî that are mandatory for French and easy to type with an AZERTY keyboard)

The problem is that Excel and Powerpoint interprets differently the keyboard keys than the layout defined in Windows, and this behavior, which leads to problems for AZERTY keyboard, cannot be changed... except if there is an hidden option somewhere?

In the meanwhile, I am becoming crazy of having an error each time in Powerpoint I enter a full stop that is changed to a comma. The AZERTY keyboard has a "." on the numeric pad, so, why interpreting it as "," ?


James
James

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks for the reply .....

Get the IME pack for french for Office to see if that makes a difference.... i guess you should be able to buy it online

Try posting the reworded version of this question on the windows forums to check if there exists a keyboard or a keyboard settings that can do what you want.....

 

BLACK BARRON


P.S : Please post back with the status of the issue. If this post was helpful to you, please vote for my post If this post has helped you resolve your issue, please mark my post as answered.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I just found that OpenOffice.org has the option that is missing in MS-Office. Without paying any "IME pack..."

Demonstration:

- Open OpenOffice.org 3.2

- Start Impress

- Go to Tools, Options, Language Settings, Languages.

- Deselect the check box "Decimal separator key: Same as locale setting (,)"

And that's it.

MS-Excel and MS-PowerPoint SHOULD have the same simple and easy option.

QED


James
James

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I just found that OpenOffice.org has the option that is missing in MS-Office. Without paying any "IME pack..."

Demonstration:

- Open OpenOffice.org 3.2

- Start Impress

- Go to Tools, Options, Language Settings, Languages.

- Deselect the check box "Decimal separator key: Same as locale setting (,)"

And that's it.

MS-Excel and MS-PowerPoint SHOULD have the same simple and easy option.

QED


James
James

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

MS Excel does have that option....Tools>> options>> Advanced >>Editor options >>Use system Seperators and there you have the option you are looking for .......

If you had asked this question earlier, we could have saved a lot of your time !!!!!

I will check on powerpoint to see if the option exists !!

 

BLACK BARRON


P.S : Please post back with the status of the issue. If this post was helpful to you, please vote for my post If this post has helped you resolve your issue, please mark my post as answered.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Sorry again, but it's not yest the solution :-(

And there were therefore not time to save with saying it before :-((((

I already tried this option in Excell and it does not change the behavior in the right sense. The option allows having the dot instead of the comma as decimal separator when DISPLAYING numbers BUT I WANT TO KEEP THE LOCAL SETTING FOR THAT, i.e. in my Excel cells, the ',' MUST remain the decimal separator. In fact, whatever is the value in the option, the '.' key of the numeric pad is ALWAYS interpreted as decimal separator by Excel, whatever is the local settings and the keyboard layout.

With OpenOffice.org, the option change HOW THE KEY IS INTERPRETED, i.e.

- either as decimal separator (and, then, the local setting value is used to decide if it is a '.' or a ',')

- or as the actual keyboard sign, and then it's always a '.' whatever is the decimal separator in the local setting or in the application.

Looking at the text of the option in OpenOffice.org, it's says well it's about how to INTERPRET the key: "Decimal separator key: Same as locale setting (,)"

Clear ?

The second behavior is the one I want because I want that all Applications use what I type ('.') without interpreting that it could be something different than the full stop that is drawn on the key.

To test any proposal, I suggest that you change your keyboard definition to AZERTY, and change the Windows local settings to have ',' as decimal separator. Then play with Excell options until typing on the '.' key of the numeric pad generates a '.' and not a ','. PowerPoint 2010 can be used also, it has the same behaviour. You can find picture of AZERTY layout on Wikipedia: http://upload.wikimedia.org/wikipedia/commons/thumb/c/ca/Azerty_fr.svg/2000px-Azerty_fr.svg.png and also here for FR-BE layout that I have: http://www.neroucheffmichel.be/html/clavierHtml/clavier/clavierAZERTY05.html

 


James
James

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks for the Info... I guess someone from MS can look at this thread... and if they do .. I would request them to  included the feature as mentioned above in office in the further fixes.... thanks for the input jmstuex

 

BLACK BARRON


P.S : Please post back with the status of the issue. If this post was helpful to you, please vote for my post If this post has helped you resolve your issue, please mark my post as answered.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Any news on this? Microsoft?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

No news that I'm aware of.  I don't have an AZERTY kbd so I've no way of testing this.

But if it were annoying me, I'd use PowerPoint's AutoCorrect feature.

As a test, I just used it to have PPT autocorrect /pd to . 

Now if I type /pd then a space, it becomes .

Voila/pd

Of course, you could use any more convenient character or characters, especially those that would never normally appear together in whatever languages you work in routinely.  ;; for example.
PowerPoint Help:
http://www.pptfaq.com/
PPTools:
http://www.pptools.com

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.