• July 17, 2017
    Announcement: New site design for Microsoft Community

    In July, Microsoft will roll out the first of ongoing site improvements aimed to modernize Microsoft Community and help customers get the most out of their community experience.

    • During the roll out period, you may see the old or new site design depending on your location

    • We expect the roll out to finish by 31 July

    Note: Past private message conversations will not move to the new site design. Please save any private messages you would like to keep.

     Learn more about the upcoming site improvements in this thread.

    Thank you for being part of Microsoft Community!

 
Question
438422 views

Outlook 2010 Mail Indexing Not Working (Windows Search Email Indexer Add-in cannot be enabled)

JB742 asked on

Outlook 2010 search not working - apparently because indexing is not working.
I'm running Outlook 2010 64bit on Windows 7 Ultimate 64bit.

Here's what I've already tried:
   * Rebuilt Indexes.  No change
   * SCANPST - No errors on pst file
   * Indexing Options - shows Microsoft Outlook in the list of "Included Locations"
   * Ran the "Troubleshoot search and indexing" - No problems found.
   * Checked-Add-ins.  "Windows Search Email Indexer" is UNCHECKED.  I can check it; but it immediately goes back to unchecked (whether I restart Outlook or not).  ** So this add-in cannot be enabled. **
   * Checked the Indexing Services in Control Panel: Programs and Features: Turn Windows Features on/off.
      "Windows Search" was checked = ON; "Indexing Services" was not checked = OFF
        I tried turning "Windows Search" OFF, Rebooted, Turned it On, Rebuilt Indexes again.  No Change.
       Checked "Indexing Service" ON;  No Change.
   ** Completely rebuilt PC (Reformat & fresh Win 7 install) **
        Exact same situation on the completely rebuilt PC

Current Status: 
   0 Items left to Index.  
   "Windows Search Email Indexer" add-in still unchecked/disabled (cannot enable)
   Outlook Search returns NO hits at all

Outlook 2010 64bit search is BROKEN.  (I've tried just about every fix suggested in the many other threads on this issue !)
Any other Fix recommendations, Please ?

JB742

345 people had this question

Abuse history


The answered status icon Answer
jasongst replied on
Found a solution! For me, at least. Forget the disabled addon, you need to enable Cached Exchange Mode.

Here is where it's located on my Win7 / Outlook 2010 box:

Control Panel >> Mail (32-bit) >> E-mail Accounts… >> Change… >> Use Cached Exchange Mode



Check the Use Cached Exchange Mode box, finish out and close the wizard, then quit Outlook and restart it. It should start caching your messages locally. Not only does this make Outlook searchable from Windows Search, it also makes your Inbox significantly faster, especially the instant searches.
118 people found this helpful

Abuse history


The answered status icon Answer
Ismail Shikalgar replied on

my Problem was resolved after deleting old  OST file and creating new one
41 people found this helpful

Abuse history


progress