Can't search emails in Outlook 2010

Outlook does not give me any answers when I search for emails.  it just tells me "No matches found for"

I have tried to re build the index, but it does not seem to do it.

However, Outlook does tell me perfectly unread emails, etc, whcih I guess are also searches.

 

Question Info


Last updated January 16, 2019 Views 425,869 Applies to:
Answer

Open Outlook click on File > Options > Search > Indexing options > Modify > Uncheck Outlook

Click on OK then close and restart Outlook to check if search results fetch correctly.


Guruprasad Ra, Microsoft Answers Support Engineer.
• We appreciate your participation in MS Forums, Help us understand your needs better. To share your valuable Feedback please Click here.

749 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer

I have been fighting this issue for months and stumbled upon this link and here is how I finally got my index working again from Outlook 2010.

 

Like most of you below I found the key "HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Windows Search" did not exist in my registry.

 

I created the key and put the string value as described here in

 

"Prevent Indexing Outlook” to “0” (without the quotes). To do this, right click on the “Prevent Indexing Outlook” key, select “Modify…”, then change the value data to “0”.

 

Once I did this, rebooted my computer I can now search contacts and email finally.

 

Hope this helps!

375 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.