In Publisher 2010 save as pdf causes png pictures to have black backgrounds. How can I fix this?

This started within the past month. Previously developed .pub files which saved as pdfs correctly now save incorrectly with no other changes made to the original .pub file. Something has changed! Is it Adobe or MS or something else? Mostly, though, how do I fix this, please?

***Post moved by the moderator to the appropriate forum category.***

 

Question Info


Last updated April 23, 2019 Views 14,500 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Does it happen with your new Publisher document?

Download PDF 995 from the link given below and then try to print to PDF, check how it is displayed. 

http://www.pdf995.com/ 

Note: The above document is not published by Microsoft. For more information on the same contact the concerned vendor.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I also get this problem in Word 2010. When I try to export documents containing PNG's or EMF images with transparent backgrounds as PDF those images get given black backgrounds. Using a tool such as PDF Creator instead works, since it is based on the print output, but then I lose all hyperlinks, table of contents etc., which is not what I want.

I would be grateful if this bug could be fixed as soon as possible and if, in the meantime, a workaround could be provided (if one exists). Thanks.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I also get this problem in Word 2010. When I try to export documents containing PNG's or EMF images with transparent backgrounds as PDF those images get given black backgrounds. Using a tool such as PDF Creator instead works, since it is based on the print output, but then I lose all hyperlinks, table of contents etc., which is not what I want.

I would be grateful if this bug could be fixed as soon as possible and if, in the meantime, a workaround could be provided (if one exists). Thanks.


If you are using the adobe reader 10.0 try installing the newer versions. There has been some reports of it not playing well with others.

Try changing your default printer. There have been reports that color in pdfs is affected if the default printer is a b&w laser for example.

What setting are you saving your pdfs to? Look under the optimize options under the File Name and Type and try switching up from high quality to standard or one of the other settings.

DavidF

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I've tested with Sumatra PDF, evince viewer and an up to date Adobe Reader. I get the same problem either way.

I tried changing my default printer to a colour one. This did not make a difference either.

I finally discovered that the problem was arising only when I had "ISO 19005-1 compliant (PDF/A)" selected under the PDF Options. Deselecting that option causes the image to be displayed correctly. Further investigation shows that transparency in objects is forbidden in "ISO 19005-1 compliant (PDF/A)" formatted documents.

Given that I had selected the PDF/A option and my document contained images with transparency, it would have been nice if Word could have warned me that the images might not render correctly rather than just generating a poorly rendered document.

Thanks for your help. It's very much appreciated.

102 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Good feedback, thanks for posting. The issue is pretty obscure and it is great you found it.

DavidF

6 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have been struggling with this for absolutely ages. I assumed it was a bug within the PDF output function of MS Office, so was looking in completely the wrong place for a solution. 

Thanks for sharing your knowledge.

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have encountered the same problem in Word 2010 today.

Fortunately I solved the problem by uncheck the ISO91900-5...(PDF/A)

When you save as PDF, clikc the Options, it's in PDF options section

Hope it helps :)

35 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks again. It worked.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This thread was great, I had been struggling with trying to change logo as I thought it was something with my transparency.  Once I found this and went to export PDF, options and unchecked the ISO button it worked!!!  Thank you very much.

5 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I've tested with Sumatra PDF, evince viewer and an up to date Adobe Reader. I get the same problem either way.

I tried changing my default printer to a colour one. This did not make a difference either.

I finally discovered that the problem was arising only when I had "ISO 19005-1 compliant (PDF/A)" selected under the PDF Options. Deselecting that option causes the image to be displayed correctly. Further investigation shows that transparency in objects is forbidden in "ISO 19005-1 compliant (PDF/A)" formatted documents.

Given that I had selected the PDF/A option and my document contained images with transparency, it would have been nice if Word could have warned me that the images might not render correctly rather than just generating a poorly rendered document.

Thanks for your help. It's very much appreciated.

Thank you. Someone should mark this thread as answered with the reply above...

5 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.