Msosync.exe uses 60% of CPU in background all the time

Hello,

 

Whenever my computer is idle, msosync.exe runs in the background and consumes about 60% of my Intel Core 2 Duo processor.  This increases fan noise, heat, and power usage on my computer, which I specifically chose because of its silence and low standby power use.

 

I am not using Sharepoint, Windows Live, Groove, Office 365, Skydrive, or whatever the latest MS cloud service is called.  Why is this thing sucking up so much of my CPU all the time, and how can I manage it?

 

When I uninstall Office 2010, msosync disappears.  When I reinstall, it comes back...and starts running again...and again...and again.....

 

Makes me want to give up on MS products completely.

 

Thank you in a advance for any suggestions or insights.

 

P.S.  Love the fact that there is no "Offfice Topic" in which this issue belongs!  But I have to choose one anyway....  Why isn't there one called "General problems with MS Office applications??"

 

Question Info


Last updated April 22, 2019 Views 79,854 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

You may follow the suggestion by 'Jennifer Zhan' from the thread link below to disable the 'MSOSYNC.EXE' and check if it helps:

http://social.technet.microsoft.com/Forums/en-GB/officeitpro/thread/f018dada-b35e-43e3-bb08-5204e2f3d113

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Aravinda,

 

Thank you for the reply.  Before posting I did search the forum and read the thread you provided.  However, it does not begin to answer my question, unfortunately -- nor did Jennifer address the original question by the other poster.

 

Jennifer's suggestion does not disable msosync.exe.  It merely hides the icon in the notification tray!

 

So, the question both the other poster and I have remains unanswered.  Why is this process consuming so much CPU time, coninuously, when we do not have any files to be synced?  It is a waste of resources, electricity, and a sign of very poor software design, as far as I can determine.

 

Hopefully you or another Microsoft expert can provide some insight into this problem, and perhaps a solution as well.

 

Thank you.

Robert

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Follow the steps below and remove 'msosync.exe' from the Windows startup:

Click Start > All Programs > Accessories > Run > Type 'msconfig'.

 

In the configuration window  > Go to startup tab > Uncheck the box for 'msosync.exe' and verify the result.

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

That is what I have done recently -- disable msosync.exe in the startup process.  This does get rid of the symptoms of high resource usage.

 

It would of course be preferable to have a solution for the cause of the problem.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Msosync is run via a task in Task Manager. To disable it:

Start >> Administrative Tools >> Task Manager >> Highlight "Task Scheduler Library".

You will see a task called "Microsoft Office 15 Sync Maintenance for..."

Right click on it and choose "Disable".

Even if you disable the task, the process for MSOSync will still be running. So, to stop it you either have to reboot, or kill the process using Task Manager.

Hope this stops your high CPU usage.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Msosync is run via a task in Task Manager. To disable it:

Start >> Administrative Tools >> Task Manager >> Highlight "Task Scheduler Library".

You will see a task called "Microsoft Office 15 Sync Maintenance for..."

Right click on it and choose "Disable".

Even if you disable the task, the process for MSOSync will still be running. So, to stop it you either have to reboot, or kill the process using Task Manager.

Hope this stops your high CPU usage.


I meet the same problem.  CPU usage was once stay at 100%.  4 steps help me to get ride of it.

 

setp1. Upate the office 2013. by "check for update"

step2, Disable the "Microsoft Office 15 Sync Maintenance for..." Task.

step3. remove the component "skydrive 2013 pro" from office 2013 installation.

step4. kill the process "MOSSYNC" in the task manger.

 

After these,  CPU usage jump back to 8%. hope this approach may works for anybody!

 

 

 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

the file lives by default in C:\Program Files\Microsoft Office\Office15 and if you rename it, you will cause the job to fail.  You can then correct the name and have stopped the process without having to reboot.  I actually don't think it is possible to kill the process in task manager as it continually respawns.

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

If other responses below didn't work foor you and if you are uncomfortable with manually editing the Registry the get the Sysinternals Autoruns application here:

--> http://technet.microsoft.com/en-us/sysinternals

Install it anywhere you want, run it and accept the license terms, and then use the Find sialog to search for 'mso' (without the quotes). The relevant entry will be that naming the executable msosync.exe. Just uncheck the box to the left.

Just a caution: this utility edits the registry and you might damage your system by changing the wrong entry. Stopping msosync, however, should not cause issues.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I renamed the file and the process stopped, renamed it back and still not running.

I am assuming though that each time I restart my PC that I will need to repeat the steps?

thanks much for the tip!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Microsoft: Lightweight task keeps Microsoft Office Document Cache in good shape. Disabling this task may lead to unexpected issues when working with documents from online sources as well as higher disk usage.

... Lightweight???

... maybe that has also to do with OneDrive desktop app... When I create a Word document on live.com and OneDrive syncs it to my destkop the msosync.exe problems starts ...

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.