Retain Arabic numbers when importing MS Excel DB into MS Word Mail Merge in Office 2010

Hi,

I am unable to retain Arabic numbers when importing Excel database into MS Word Mail merger.

I have tried all the regional and language settings but not luck. Also tried File Format Conversion Option and MS Excel Worksheets via DDE still no luck.

please help..

|

Hi,

It is maybe caused by the auto-correct of Word.

http://answers.microsoft.com/en-us/office/forum/office_2007-word/while-typing-arabic-all-dots-between-digits-change/0d88b2a0-8ab8-4bd2-a9df-14612eb538c5

Try to disable the auto-correct feature in Word.

Kind regards,

JP Ronse

If this response answers your question then please mark as Answer.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

no luck. tried also - http://support.microsoft.com/en-us/kb/212349.. still not working. is this something to do with region and landuage setting? i am able to type in arabic, retain arabic text but cannot not the arabic numbers when mail merge database imported from excel 2010 to word 2010. 

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hello

When you say "Arabic numbers", you mean the Eastern Arabic numerals (called "Hindi" in Office), that is, ١، ٢، ٢، ٤... etc?


If yes, how did you make them "Arabic"  in Excel?

One solution for this case is to make the Numeral option (File > Word Options > Advanced > Show document content) "Hindi" in Word settings. This will make all your numbers look Eastern Arabic.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hi,

I tried that.. But problem is when I change to Hindi all the numbers changes to Arabic. My excel DB have mixture of English and Arabic numerals to be imported into the mail merge word documents. As mentioned finished mail merge word documents has English and Arabic numerals.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Does your Excel file contain column(s) with English text? I'm asking this because Word (when the Numeral is set to "context") has this funny behavior with numbers when it comes to mail merge. If the cell containing a number is preceded by a text cell, the "language" of the number in Word will appear depending on the language of the text.

Can you rearrange your Excel columns accordingly? If no, can you add a column, with one Arabic letter in its cells (you can hide this column), before the  column of numbers that you want to appear "Eastern Arabic" in Word (no matter how it looks in Excel)?
 
Beware! This could affect other adjacent number columns.

5 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Example:

Columns added:


columns hidden:


Mail merge result:


3 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated May 8, 2021 Views 656 Applies to: