Opening excel file directly is very slow

I can open Excel directly and it launches immediately - not an issue.
I can launch Excel directly and then open a file - it opens the file immediately.
However if I open a file directly - without previously launching excel - it takes a long time - 30 to 40s.

I have tried many suggestions found online but none help. Does anyone have any ideas please?

Win 7 64 Bit
Office 2010

Thanks


 

Question Info


Last updated September 20, 2018 Views 82,468 Applies to:
Answer
Solved.......I worked it out from searching the internet.
The issue is Superfetch. Mine was switched off.
As soon as it was turned on from Regedit followed by me starting it in Services - it works perfectly!

Here is the text from the solution....

I found this on Technipages website:

Mitch wrote:

"Superfetch caches data to RAM so that it can be immediately available to your application. Sometimes this can affect the performance of certain applications. It tends to not work well with gaming, but can improve performance with business apps.

To modify whether Superfetch is enabled or disabled, you can perform the following steps:

1. Click the Start orb and type REGEDIT in the Start Search area.

2. Open the Registry Editor.

3. Click the plus sign next to HKEY_LOCAL_MACHINE
then SYSTEM
then CurrentControlSet
then Control
then Session Manager
then MemoryManagement
then click PrefetchParameters

4. On the right side, double-click on EnableSuperfetch

5. Give it one of the following values:

0 to disable Superfetch
1 to enable prefetching when program is launched
2 to enable boot prefetching
3 to enable prefectching of everything

Hit OK then Close RegEdit. "


Then goto the services MSC ("windows key + r" or just "windows key" and type services.msc). Scroll down to Superfetch and now should start. Click Start on the left info pane or double click it and change to automatic, then attempt to start again.


For informational purposes I chose the 4th option to enable prefetching for everything.

Hope this helps.


A.J. Silverman
MCSE+I, MCP, A+

108 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.