F2 key in Excel 2010 opens snipping tool instead of editing cell

My office computer has Excel 2010 and I'm no longer able to use the F2 function key to edit cells. I've checked under options in Excel and the function is enabled. But every time I click F2, the snipping tool opens up. I've tried disabling the Snipping Tool but then when I hit F2 it then tells me that the function doesn't work. Can anyone help me with editing my function keys? Thanks a million!

 

Question Info


Last updated August 25, 2019 Views 2,028 Applies to:

Hi,

Thank you for posting in Microsoft community.

As per the description provided, you are unable to edit a cell using F2 function key.

Let me assist you with editing cell in Excel.

 

I have a question for you.

Are you able to double click on the cell and edit?

Verify if the option is check in Excel 2010.

Open Excel, File, Options, Advanced, Editing options, check the box 'Allow editing directly in cells' and press ok

 

Also check if it happens with other keyboard.

 

You may also refer to the troubleshooting steps mentioned in the article below:

http://support.microsoft.com/kb/894513

 

I hope the above steps help. If you need any further information you can always reply and I’ll be happy to help you.

Thank you.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.