Excel won't open maximized

Tried setting the starup icon properties to start maximised. Tried setting registry entry HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Excel\Options\Maximized to 0x00000003

All to no avail. I've sen the prob reported on lots fo other forums but it's always the solutions noted aboive that are suggested, and jsut as reported on those forums, they don't resolve the issue with Excel 2010.


sh
 

Question Info


Last updated May 7, 2020 Views 47,347 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

The following works for me.

Open the file. Maximize it. Then close it. Open it again and it will be maximized.

11 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Alas, that doesn't do it. After some further research it appears that there is a bug in Excel 2010 -- if you use a personal file, as in prior versions, to store macros, and keep it in the xlstart directory so the macros are available when you start Excel, and start by calling excel.exe then Excel won't open maximized. Not even if you jump through all the hoops that worked on prior verson of Excel. There's been enough complaining about this issue, I was hoping someone had a fix or at least notion that MS was working on the prob in an update.

 

 

 


sh
sh

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Grasping at straws here since I don't have 2010, but one thing that works in some applications is to:

  • open,
  • maximize,
  • then hold the Shift key down while clicking the close button. 

Works (usually) for IE (XP and Vista), and has worked for XL2007 on Vista for me

78 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks for the suggestion. It too fails to fix matter. Seems to especially stubborn in Excel 2010. Apparently if you open a hidden personal file to load macros, you will never get a maximized Excel on startup in the 2010 version. Guess we wait for the SP1 and see what happens.
sh
sh

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Am 28.06.2010 14:26, schrieb shieber:

<meta http-equiv="Context-Type" content="text/html; charset=utf-8"> Thanks for the suggestion. It too fails to fix matter. Seems to especially stubborn in Excel 2010. Apparently if you open a hidden personal file to load macros, you will never get a maximized Excel on startup in the 2010 version. Guess we wait for the SP1 and see what happens. sh
If you load a personal file why did you do not maximize the application by your own?

Andreas.

Private Sub Workbook_Open()
  Application.WindowState = xlMaximized
End Sub

5 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

The personal macro workbook is hidden by default, choose View, Unhide.

Note: you do not need to view the spreadsheet to be able to modify the macros, just press Alt+F11, you will see the file displayed on the top left as Personal, expand its Module folder and double-click any Modules


If this answer solves your problem, please check, Mark as Answered. If this answer helps, please click the Vote as Helpful button. Cheers Shane Devenshire
Shane Devenshire

6 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

One, the personal notebook is loaded automatically by Excel, without any coding required (it autoloads the personal.xls in C:\Documents and Settings\[username]\Application Data\Microsoft\Excel\XLSTART

 Two, because you never had to do that with previous versions;

Three, because sometimes you do want to load non-maximized and it was easier to have a couple of icons to control this (one for nomram and one for maximized) than the have to hard code it intop the personal file.

 


sh
sh

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Yes, it's not the fact that it's hidden that's at issue. I realize a workaround is to make an auto-run macro in the auto-load speadsheet so that it opens maximized everytime regardless of whether you try to start it normal or maximized.

 IN fact, it's only when the file is hidden that Excel won't load maximized. If it's saved unhidden, then excel will load maxmized (or however icon prperties are set) -- then, if you hide the perosnal spreadsheet and clsoe Excel, thereafter it won't load maximized.

Another workaround it to manualyl maximize the window after Excell 2010 loads. IT was much better when you could control this by the property setting in the icon used to sart the program. IN this re Excel 2010 doesn't hold to the standards very well.

It sure was easier to get this simple thing the way you wanted it in priior verisons. I'm still hoping SP1 corrects this deficit in the design.


sh
sh

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

It appears you used two different icons to start Excel, one that opened it maximized, the other did not.  If so, I suspect, you were using a command line switch to control how Excel opened.  AFAIK, Excel 2007 and 2010 removed many if not all of the switches.

You could use a VBS script to accomplish the same.

Save the below as, say, XLmax.vbs

Set WshShell = WScript.CreateObject("WScript.Shell")
wshshell.run """c:\program files (x86)\Microsoft Office\Office14\Excel.exe""",3

Save the below as, say, XLreg.vbs

Set WshShell = WScript.CreateObject("WScript.Shell")
wshshell.run """c:\program files (x86)\Microsoft Office\Office14\Excel.exe""",1

Double-click the first to open Excel with its window maximized, the second to open it with 'normal' focus.

You can experiment with the last argument.  See

Run Method (Windows Script Host)
http://msdn.microsoft.com/en-us/library/d5fk67ky%28VS.85%29.aspx

Yes, it's not the fact that it's hidden that's at issue. I realize a workaround is to make an auto-run macro in the auto-load speadsheet so that it opens maximized everytime regardless of whether you try to start it normal or maximized.

 

Another workaround it to manualyl maximize the window after Excell 2010 loads. IT was much better when you could control this by the property setting in the icon used to sart the program. IN this re Excel 2010 doesn't hold to the standards very well.

It sure was easier to get this simple thing the way you wanted it in priior verisons. I'm still hoping SP1 corrects this deficit in the design.


sh

Tushar Mehta (Technology and Operations Consulting)
www.tushar-mehta.com (Excel and PowerPoint add-ins and tutorials)
Microsoft MVP Excel 2000-Present
Tushar Mehta (MVP Excel 2000-2015)
Excel and PowerPoint tutorials and add-ins
www.tushar-mehta.com

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

No, not a command line switch, jsut the propert setting for the icon -- right click any icon, select Propoerties,  and you'll see a setting called "Run" which allows yo to set for Maximized, NOrmal, of Minimized. It works for most programs, but not Excel 2010.
sh
sh

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.