Hyperlinks in Word 2007 are showing up in brackets instead of blue underlined text, but not in print-preview mode

In Microsoft Office Word 2007, my hyperlinks are showing up strangely. When select text and hit CTRL K or the Add a Hyperlink button and then input a Web address into the correct line, a link appears, but not the way I want it to. The text I had highlighted is deleted and replaced by the Web address, surrounded by brackets {}. However, when I look at a print preview, it looks normal and I see that the highlighted text was not deleted, but it is blue and has the underline of a hyperlink, like I wanted it to have. I tried emailing the document to another person and it looks fine in his Word 2007 version. I also found that when I open documents I had added links to before, they have this same problem. All of their links look wrong, though they are correct when I look at a print preview. I want to be able to see the hyperlinks normally instead of in their bracket form, which looks like this:
{HYPERLINK "http://www.bing.com/"}

How do I get Windows 2007 to go back to normal in terms of displaying hyperlinks?
 

Question Info


Last updated October 17, 2019 Views 84,263 Applies to:
Answer
Answer
Never mind, it's in the same screen, a little further down in the Print section - Print field codes instead of their values. That means if you actually want to show the hyperlink for a course handout, you can.

So ALT-F9 toggles the code view on and off, but to print the codes you have to go into the Options/Advanced/Print section menu and change it.

62 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer
Answer
I found out the solution! It was hidden in the options. I discovered that the term for those hyperlinks is "field codes." To change the settings so it shows the value instead of the field code, which is what I was trying to do, you click the office button on the top left-hand side of the Microsoft Word 2007 page. It's the circle with the Office logo. Click "Word Options" on the bottom of the dropdown menu. Click the "Advanced" tab and scroll down to the "Show document content" section. Right above the "Field shading" box, there is an option that says, "Show field codes instead of their values." If that has a check next to it, unclick it and hit OK, and your hyperlinks will return to normal in your Word documents. There you have it! Problem solved.

186 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.