Weird "File in Use" error opening Excel 2007 Files on the network.

We are having weird problems when trying to open 2007 Excel files. I have seen some similar problems listed on different forums etc but nothing that seemed just like what we are experiencing.

 

Here is our configuration and what I have found out so far.

 

·       The problem occurs any time we double-click a XLSX file located on the network and Excel is already open

o  We get the “File in Use” error: “<filename> is locked for editing by ‘another user’. Open ‘Read-Only’ or click ‘Notify’ to open read-only and receive notification when the document is no longer in use.

o  We have verified that when this happens *NO ONE* is accessing the file and according to the server the file is not being accessed

 

·        If Excel *IS NOT* already open it works

·        If the file is located on the local machine it works

·        If we convert the file to a XLS format it works

·        If we copy the file to another network location and double-click it works

o  THE FIRST TIME ONLY

o  After the first time it always fails

·        In Excel if we goto OPEN, browse and then select the file it works

o  The same if we open it from the list of Recent Documents, it works

·        If we click on “Notify” when we get the error message within 10 seconds it says it is available and we click “Read-Write” and it works

·        If we Right-Click on the file and select “OPEN” it works

·        But if fails every time if we double-click a XLSX file that is located on the network when Excel is already open

 

·        We are running Windows 7 64-bit enterprise edition

·        Office 2007 SP2

·        The Excel Option  Advanced | General, "Ignore other applications that use Dynamic Data Exchange (DDE)" is already unchecked

 

 

As you can see we can work around the problem but it is very annoying to our users

 

If you have seen this problem and know of a fix I would appreciate knowing what you found out.

 

Question Info


Last updated August 15, 2019 Views 189,174 Applies to:
Answer
Answer

We were having this problem with several users from remote locations accessing Excel files on a file server.  The clients are Windows 7 Pro systems connecting to a 2003 R2 server. I suspect this would also occur with 2008/2008r2 servers, but I have not tested it.  It does not occur with XP clients. The file was getting a lock on it even though it was not being opened.  The file lock would last 10-20 seconds before being released. There are three things that contribute to this problem, all of them Windows Explorer related:

  1. Selecting the file in Explorer -just highlight it without opening
  2. Hovering over the filename so that the pop-up file information box was displaying
  3. Using the Preview Pane in Explorer

To fix the problems:

  1. Turn off the Details Pane shown at the bottom of Windows Explorer.  Go to Organize -> Layout -> Details Pane.  That fixes the first problem.
  2. Turn off “Show pop-up description for folder and desktop items”  Click on Tools -> Folder Options.  In the box that opens up, click on the View tab.  Scroll down the list to “Show pop-up description for folder and desktop items” and clear the checkbox and then click OK.  This fixes the second problem.
  3. Turn off Preview Pane.  Go to Organize -> Layout -> Preview Pane. This fixes number 3. 

The preview pane is not on by default in the "Details" view, but the other two options are on by default.  The file locks are created when Explorer is gathering file information like size, author, modified date, etc..  I suspect that it would also do this with any other file type, but I have not tested that situation either.  For those of you in a managed environment (I guess that would be anyone reading this since the likelihood of home users having this problem would be approaching zero), I am going to use regmon to see what registry keys are modified by the changes.  I will post them so that you can deploy them to your environment if I find them.

 

 

44 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer
Answer

Here's the keys that you need to set - save the following as a .reg file

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced]
"ShowInfoTip"=dword:00000000


[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Modules\GlobalSettings\Sizer]
"PreviewPaneSizer"=hex:35,00,00,00,00,00,00,00,00,00,00,00,bd,02,00,00
"ReadingPaneSizer"=hex:04,01,00,00,00,00,00,00,00,00,00,00,64,02,00,00

 

I tried using the HKLM hive and it did not work, so it needs to be a per user policy.  Come on Microsoft, administrators should be able to set these kind of keys at the machine level to apply to all users. 

3 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.