• July 17, 2017
    Announcement: New site design for Microsoft Community

    In July, Microsoft will roll out the first of ongoing site improvements aimed to modernize Microsoft Community and help customers get the most out of their community experience.

    • During the roll out period, you may see the old or new site design depending on your location

    • We expect the roll out to finish by 31 July

    Note: Past private message conversations will not move to the new site design. Please save any private messages you would like to keep.

     Learn more about the upcoming site improvements in this thread.

    Thank you for being part of Microsoft Community!

 
Question
31132 views

Change default program for Excel hyperlink

timfgee asked on

I cannot make Excel open a hyperlinked file with anything but internet explorer. I am using Excel 2007 and Windows 7 64-bit. Previously, when using Windows XP, I was able to fix this problem by adding a DWORD named ForceShellExecute set to 1 to the registry at HKEY_LOCAL_MACHINE\Software\Microsofte\Office\9.0\Common\Internet. However, in Windows 7 64-bit this location doesn't exist, and the same fix does not work.

 

48 people had this question

Abuse history


The answered status icon Answer
centaurusa replied on

I cannot make Excel open a hyperlinked file with anything but internet explorer. I am using Excel 2007 and Windows 7 64-bit. Previously, when using Windows XP, I was able to fix this problem by adding a DWORD named ForceShellExecute set to 1 to the registry at HKEY_LOCAL_MACHINE\Software\Microsofte\Office\9.0\Common\Internet. However, in Windows 7 64-bit this location doesn't exist, and the same fix does not work.

 

I finally found a registry fix for Windows 7 that will allow Excel to hyperlink to JPG`s in the image viewer that is set by the file association for .JPG rather than always using Internet Explorer.

The original solution was posted by Daniel Stawicki in his (Polish) blog entry “Hyperlinki do plików jpg w Excel 2010/2007 otwieraja sie w IE8”.  For those who don`t read Polish (me included!), Google Translate will provide enough information for you to figure out how to apply the patch.  However, since the translated text  (particularly the value data to be changed) is a little garbled, the following step-by-step instructions may assist:  

(1) Run  regedit.exe

(2) Navigate to HKEY_CLASSES_ROOT -> jpegfile -> CLSID

(3) Right-click on “Default” (the Value Name) and select “Modify”

(4) Change “Value data” from {25336920-03F9-11cf-8FD0-00AA00686F13} to {FFE2A43C-56B9-4bf5-9A79-CC6D4285608A}

This registry patch is said to fix the problem for both Excel 2007 and Excel 2010 running in Windows 7.  It certainly works for Excel 2010.  I haven`t tried it with Excel 2007.
28 people found this helpful

Abuse history


progress