Why does Teams audio device keep resetting to USB?

In Teams, I find the device settings repeatedly revert to USB settings, despite speakers/headphones being set.

In the past, some apps have behaved dynamically to reflect the device present, for example, Skype would change from speakers to USB headset when the latter is plugged-in.

However in this case, for Teams, no device of this type has been plugged-in. Unit is Dell Latitude 7280 (a very troublesome and unreliable model) and it's using a USB-C dock. Speakers would usually be plugged into the unit itself, rather than the dock.

The issue has been a problem, causing me to miss the audio in the start of calls, on occasion when someone's been speaking to me, which isn't good for a business environment.

Thanks for any help,

Tom S

|

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi Tom,
Do you have another application using the headset? Teams will drop to the devices not used by another application.

In my case, I wanted to use my speakerphone, not the headset but it keeps switching to the headset because gotomeeting uses the speaker phone.

Which version of Teams do you have installed?
Diane Poremsky [Outlook MVP]
Outlook Resources: https://www.slipstick.com
https://www.outlook-tips.net

** I don't work for Microsoft.**
** DO NOT CALL phone numbers received in email notifications.**

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hi Diane,

Teams Version 1.3.00.13565 (64 bit).

I'm not using any other application with the headset. This is the odd thing, in previous times that would be the case, and as mentioned, some apps will intelligently switch to the USB headset if plugged in, or the speakers if not. In this case, due to lockdown, the last few weeks I've only been using speakers, and yet the setting keeps changing back. I'm not plugging in anything unusual into the USB ports, only general, regular items such as charging a phone.

Thanks,

Tom

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

If you dont plus in the phone, does it change? I'm wondering if windows is detecting the phone as mic/speaker.
Diane Poremsky [Outlook MVP]
Outlook Resources: https://www.slipstick.com
https://www.outlook-tips.net

** I don't work for Microsoft.**
** DO NOT CALL phone numbers received in email notifications.**

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I've tested, and plugging in a phone doesn't cause this.

And I've now tested by simply signing out and back in, and sure enough, it's resetting just via that action, so something quite basic seems wrong here?

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Ok, so its not the phone... the headphones are not skype certified? (I assume they pre-date Teams - but certification for one should be ok in the other).
Diane Poremsky [Outlook MVP]
Outlook Resources: https://www.slipstick.com
https://www.outlook-tips.net

** I don't work for Microsoft.**
** DO NOT CALL phone numbers received in email notifications.**

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

The headphones or speakers are just going into the jack socket, not USB or anything else. So no issue there. I've fixed the problem by simply disabling the USB option in the Windows audio settings, but of course if this doesn't re-enable automatically when I next use USB headset, I'll get caught out the opposite way round.

I think this is a bug that needs escalating, and it seems a little backward because as mentioned, devices automatically detected and switched worked fine in the past with Skype for business? (Not tested that lately).

Thanks, Tom

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I'll pass it along to my contacts in the product team.
Diane Poremsky [Outlook MVP]
Outlook Resources: https://www.slipstick.com
https://www.outlook-tips.net

** I don't work for Microsoft.**
** DO NOT CALL phone numbers received in email notifications.**

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Thanks Diane -

Tom

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

You're welcome!
Diane Poremsky [Outlook MVP]
Outlook Resources: https://www.slipstick.com
https://www.outlook-tips.net

** I don't work for Microsoft.**
** DO NOT CALL phone numbers received in email notifications.**

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I also experienced the same behaviour

I have a steelseries 5 headset, linux ubuntu 20, and a Version 87.0.4280.66 (Official Build) (64-bit)

Whenever I try to change to my headset in the settings in teams after approx 10 sec it will swicth  to Cannon Lake PCH cAVS Digital Microphone and Cannon Lake PCH cAVS HDMI3/DP3 output

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Question Info


Last updated June 8, 2021 Views 1,589 Applies to: