Teams for Mac High CPU usage (macOS Mojave 10.14.6)

Hello,

When I use video calling on Teams for Mac, the CPU usage goes haywire using over 70%+ CPU to the point that my Mac overheats and sounds like a hover.

Any help out there?

Thanks! 

Before a video call

During a video call

|

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hello Aaron196,

My name is Juan Pedro, I am an Independent Advisor and consumer of Microsoft products. I will be more than happy to assist you today!

Have you tried to uninstall and reinstall Teams?

Also, you could try removing unused apps on your computer or close unused apps while using Teams.

I hope this helped. I will be around in case you need something else.

Thank you.

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Juan

I have the same issue

Teams on macOS Cat 10.15.4, 10th gen i7

Teams idle temp 55c fans at 1500ish

Teams on a call 70c 6000rpm, and 90%+ CPU!

Is there a fix?

4 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I have the same problem as well. Couple of google searches and I'm seeing this same issue posted on a variety of sites.

Teams works well when NOT doing a video chat. Video chats, especially with multiple people, cranks up CPU usage and fan spins unbearably loud.

Someone smarter than me mentioned on a forum that it could be a video encoding issue.

Hoping MS looks into this soon Fan is so loud that people can't hear me over it when I speak during meetings

8 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I've also noticed, this issue worsen when using ones own camera and providing video out.

Hope that helps MS sort this long standing issue out ASAP.

3 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

i think i found it.

though its mailnly for windows, it worked for my macbook air

https://www.itexperience.net/fix-performance-issues-teams-high-cpu-memory-usage/

4 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Thanks for the suggestion.  The same tip to disable GPU has been suggested for Mac computers as well.  

At least with my tests this does not offer a notable difference in performance - as other posters mention, when you activate webcam for calls then the CPU goes crazy and the computer fans spin up to max.  Same with or without GPU disabled!

Running the app in the background alone doesn't affect performance for me, its just when calls are ongoing.

2 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Thanks for the suggestion.  The same tip to disable GPU has been suggested for Mac computers as well.  

At least with my tests this does not offer a notable difference in performance - as other posters mention, when you activate webcam for calls then the CPU goes crazy and the computer fans spin up to max.  Same with or without GPU disabled!

Running the app in the background alone doesn't affect performance for me, its just when calls are ongoing.

i actually tried it today after some horrible calls that made my GPU jump through the roof. 

i toggled it off, closed Teams completely,  cleared cache and the following 3 video calls went very well.

did you clear cache? 

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

did you clear cache? 

Hi CHENio,

I noticed where to toggle off GPU in teams settings, but where do you clear the cache?

Will I just clear the cache in Safari?

Thank you.

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

did you clear cache? 

Hi CHENio,

I noticed where to toggle off GPU in teams settings, but where do you clear the cache?

Will I just clear the cache in Safari?

Thank you.

sorry, was sure i posted that as well.

you can see it here: https://medium.com/365uc/how-to-force-refresh-rebuild-of-microsoft-teams-client-cache-e92b7739fca3

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Same here. Macbook Pro 16, Intel i9 8 core, when in video calls with more than 2 people, it goes to 90 degrees and stays there.

I've noticed that actual reported CPU usage does not seem to be an issue, because this CPU is a beast and handle a lot, but Teams somehow determines the CPU to boost multiple cores to turbo frequencies.

I guess it's multi-threaded, but with low-load. So multiple cores receive some workload, the CPU boosts them to higher clocks to ensure high core performance, and even though the actual CPU usage is not high, there is this high thermal load. And then that performance is somehow wasted, because those boosted cores are not 100% used.

Maybe less threads that are more time occupied would actually work better than more threads, with less load for each?

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Question Info


Last updated May 12, 2021 Views 16,378 Applies to: