Microsoft Teams using dGPU even with 'Disable GPU hardware acceleration' Turned ON - Teams on MacBook Pro 15

Teams drains my battery very fast as it forces the use of the dGPU in calls, While attending a meeting, activity monitor shows dGPU use by teams.

The dGPU use is only when I am in a meeting, it is not present while in the teams home screen.

I have turned on the option to disable gpu hardware acceleration and the problem still persists. 

I have reinstalled teams and deleted the Caches from library. The problem still seems to persist.

How can I make teams use my integrated graphics to preserve battery life?

Thank you

|
Hi, I'm Sergio, an Independent Advisor and Microsoft Team customer just like you, and it's a pleasure to help you.

This issue have many causes and possible resolutions:

Solution 1: Switch to Microsoft Teams Web Microsoft Teams is available as a web app or as dedicated software for Windows od macOS. In case you experience the problem while using thededicated app, please try to switch to the web app and check if the problem persists. You can sign in to Microsoft Teams web

If you click on the meeting invite (for example, in Outlook) you will
be asked to join a meeting via Microsoft Teams web or to open
Microsoft Teams app on your Windows or macOS. Don’t forget to enable pop-up notifications, so you are up to date with new messages or channel updates.

Solution 2: Disable GPU hardware acceleration
1. Open Microsoft Teams. Click on your profile photo and then click on Settings
2. Under application select Disable GPU hardware acceleration
(requires restarting Teams)
3. Close the Microsoft Teams. Clicking on the close button in the
Microsoft Teams will not kill the process, but minimize it to the
taskbar.
4. Open Microsoft Teams and check if the problem persists.

Solution 3: Disabling Read Receipts
1. Click on your profile picture and then select Settings.
2. Now, select Privacy. Here, you will find the option of ‘read’ receipts.
3. Disable Read Receipts, save changes, and exit.

Solution 4:
You must follow the answer of an other advisor about the same trouble in:
https://answers.microsoft.com/en-us/msteams/for...

Greetings.

Was this reply helpful?

Yes
No

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Very interesting. I had quite the opposite - screen flicker during other people's screen sharing. Disabling GPU Acceleration for Teams on a MBP late 2016 fixed it.

Also, I now all the time, before starting teams, clear the caches etc. as described here:

removing these files/folders:

  • “~/Library/Application Support/Microsoft/Teams/Application Cache/Cache”

  • “~/Library/Application Support/Microsoft/Teams/blob_storage”

  • “~/Library/Application Support/Microsoft/Teams/Cache”

  • “~/Library/Application Support/Microsoft/Teams/databases”

  • “~/Library/Application Support/Microsoft/Teams/GPUCache”

  • “~/Library/Application Support/Microsoft/Teams/IndexedDB”

  • “~/Library/Application Support/Microsoft/Teams/Local Storage”

  • “~/Library/Application Support/Microsoft/Teams/tmp”

using a simple shell script such as

#!/bin/bash

ps ax | grep -i "Microsoft Teams.app" | grep -v grep | cut -b -5 | xargs kill -9

cd ~/Library/Application\ Support/Microsoft/Teams && \

for i in Application\ Cache/Cache blob_storage/ Cache/ databases/ GPUCache/ IndexedDB/ Local\ Storage/ tmp/; do rm -rf $i; done

open /Applications/Microsoft\ Teams.app &

HTH,

M

Was this reply helpful?

Yes
No

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated July 27, 2021 Views 2,173 Applies to: