Cannot associate .doc type with word 2010

I am having trouble associating .doc with word 2010.  If I right click / Open With / Choose Default... and select winword, nothing will happen (it does not recognize this as a valid choice).  I found that by renaming winword to winword.exe, it will allow me to associate the file by the aforementioned method.  However, after doing so, when I try to open a .doc file, I will get an error msg: "There is not enough memory or disk space to run Outlook".

Has anyone had this problem?  Solutions?

 
Question Info

Last updated July 11, 2018 Views 4,064 Applies to:
Answer

http://www.word.mvps.org/FAQs/AppErrors/ReRegisterWord.htm describes how to make Word fix its registration very simply.

I'm worried by your statement about "renaming winword to winword.exe". Word's executable file is already named winword.exe, so that makes me think that you have the (stupid stupid Microsoft!) default
setting of "Hide extensions for known file types" in Computer > Tools > Folder Options > View. Having done the renaming, you now have a file named winword.exe.exe, which is why Windows can't find it
to open a .doc file. Go into the Folder Options dialog and turn off that option, then rename winword.exe.exe back to just winword.exe before you try to follow the instructions in the article I
mentioned.


Jay Freedman
MS Word MVP  FAQ: http://word.mvps.org
_____________________________
https://jay-freedman.info

Did this solve your problem?

Sorry this didn't help.