Word 2016 still slow / laggy after 15.30 update

Hey All, 

I installed Office 2016 about 2 weeks ago, and so far I'm not particularly impressed. The most pressing issue for me at the moment is extreme lagginess in Word. Words are slow to appear when typed, cursor movement is laggy when using arrow keys to move it around, scrolling is laggy also. 

I realise other people have posted about this issue previously, but according to Microsoft's changelog for word it was fixed by the v15.30 update. Unfortunately, the update did not fix the issue for me! Furthermore, I'm now running v15.31 and it's still not fixed.  

Anybody have any ideas or experiencing the same on 15.30 or 15.31? I've tried cleaning my Mac of caches and junk files that I thought may be lingering around in Office and could be the cause of the issue, but no luck. Any help would be greatly appreciated. 

I still have Office 2011 installed so will be reverting back to it until another update is pushed out. 

|

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Try repairing your Office 2016>Control panel>Programs and Features>Right click on Office 2016>Choose 'Change'>Choose 'Quick Repair'

Repair an Office application

Microsoft Office Home and Business 2019
Microsoft Office Home and Business 2013
Microsoft Office Professional 2003
Windows 10 Professional
HP ProBook 470 G4

Was this reply helpful?

Yes
No

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Thanks, Ron, but I'm experiencing these issues on a Mac, where I cannot seem to find any such control panel. This Office apps (word, pp, excel and outlook) simply sit in the root of the Applications folder, with no additional supporting control panel folders etc. 

I've tried reinstalling Office 2016 over the top of the previous install but that didn't help. Guess I'll try completely removing it then reinstalling it fresh. 

Was this reply helpful?

Yes
No

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Another user has reported a slow interface in Word 2016 for Mac when they had the Magnet app installed. Removing it restored the speed they expected.

Another user mentioned that when they used Help>Check for Updates, then joined the Office Insider program on the Slow track, that the 15.31 update solved the problem for them.

To uninstall Office, please follow these steps: Uninstall Office 2016 for Mac Otherwise the problem will simply reappear.

Author of "OOXML Hacking - Unlocking Microsoft Office's Secrets", now available
John Korchok, Production Manager
production@brandwares.com

1 person found this reply helpful

Was this reply helpful?

Yes
No

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Thanks, John, but still no luck. 

While I do normally use Magnet, I uninstalled Magnet completely, restarted my Mac and confirmed that the Office 2016 lagginess persists even in the absence of Magnet. Upon further use, it turns out that Excel is actually even worse affected than Word!

Am not on the insider program, but I am running the latest version of Office (currently v15.31), and I check for updates frequently in the hope of a fix.

Finally, I completely uninstalled Office 2016 (using AppCleaner, which removes all the additional rubbish that would otherwise be left behind), rebooted my Mac, then downloaded and reinstalled the latest version of Office 2016. Unfortunately the lagginess persists in both Word and Excel. PowerPoint seems fine, however, I've never had issues with PP being slow, only Word and Excel.   

So no luck in resolving this lagginess yet.  

Was this reply helpful?

Yes
No

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hi Jon267,

To make sure that the issue is not related to the issue on 15.29, please try the following steps and see if it helps:
Go to System Preferences > Security & Privacy > Privacy > Accessibility, let us know which apps are under "Allow the apps below to control your computer". A related screenshot would be grateful.

2. Uncheck all the applications listed there. Restart Word and check whether the issue persists.

Note: Revoking accessibility permissions from 3rd party apps in the steps above will likely cause the 3rd party apps to stop functioning as intended. Re-enabling permission (Re-checking the checkbox) should return the 3rd party apps functions to normal.

Regards,
Sheen

-------------------------------------------------
If you feel a reply works for you, please kindly vote or mark it as it will be beneficial to other community members reading this thread.

Was this reply helpful?

Yes
No

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hi Sheen, thanks for the suggestion. 

In my Accessibility I had Dropbox and Magnet enabled (also have Image lab listed but it wasn't enabled).

I opened Word and Excel and confirmed the issue was occurring. I then quit them both, then disabled everything in Accessibility. I then re-opened Word and Excel and can confirm that the problem persists in both apps. I then rebooted my Mac and tried Word and Excel again, but still no luck I'm afraid. 

2 people found this reply helpful

Was this reply helpful?

Yes
No

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I have an update on this issue, well in relation to Excel at least anyway. 

The problem is completely related to using Page layout view within Excel. I created a temporary document, then created a copy. When using 'Normal' view, Excel is snappy with responsive scrolling, i.e. normal. In 'Page Layout' view though, there's extreme lag, slow scrolling etc, despite being the content being the same. 

That solves the issue with Excel, but it's still an annoyance as I prefer to work in page layout view I usually end up needing to print the spreadsheets I work with. Hopefully a fix for this will come soon. 

I'll mess around with different views in Word and see what I find. 

Was this reply helpful?

Yes
No

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hi Jon267,

 

To move forward, we’d like to confirm the following information:

 

1. Whether the temporary document is a newly created one or a copy of the original file? If not, please create a new file then copy the data to the new file and see whether the problem persists.

2. We will send you a test file via Private Message to check whether the test file still have the problem.

3. Would you please record a video for us to clarify your situation? You can provide the video in the Private message.

 

Regards,

Tisky

Was this reply helpful?

Yes
No

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hi Tisky, 

To answer your queries:

1) It was a newly created document. I suspected that using an older file might be the issue so I created a brand new file within Excel 2016, and still observed the lag in page layout view, but no lag in normal view. 

2 and 3) Done. Please check you inbox for a link to download the video capture. 

I've also noticed that the same does apply when working in Word. i.e. Page layout view is slow and laggy whereas draft view is fast and snappy. Unfortunately I've had to endure the lagginess of page layout view recently as the stuff I'm working on has to fit within specific limits. 

EDIT: actually, I stand corrected. Draft view does NOT help with the lagginess I'm experiencing with Word 2016. Have been working with a Word document all day today, and it's been slow and laggy working in Draft view, in addition to Page layout view. The word document was created within Word 2016, not a previous version of Word. Am posting this as the lag has gotten me fed up to the point where I felt I needed to revert to using Word 2011. 

Was this reply helpful?

Yes
No

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hi Jon,

 

Thanks for the information, we understand your frustration, please bear with us while we collect the necessary information.

 

In Word, there is no Page Layout view, please provide us with the view that are affected in Word:

Switch to different views in Word 2016 for Mac.

 

We would also like to collect a video of Word 2016 for Mac's lag, your OS version. I have replied to your private message to collect the video.

Regards,

Sheen

-------------------------------------------------
If you feel a reply works for you, please kindly vote or mark it as it will be beneficial to other community members reading this thread.

Was this reply helpful?

Yes
No

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Question Info


Last updated June 12, 2020 Views 1,304 Applies to: