Retaining date history on photographs in SharePoint

I need to copy a very large number of photographs into SharePoint, but I notice when I do this, the date and time information as to when the photo was taken, is removed.  All that is visible on SharePoint is the date the photo was copied across.   If you open the photo from SharePoint, there are no "Properties" to view as it opens in PDF or Paint.   The only way to view the date and time information is to actually download the photo and view it in something like Windows Media Centre or Windows Photo Viewer - which you can only do one at a time.    

Is there a way of preserving the time and date information when a photo is copied into SharePoint?

|
Answer
Answer

Hi Katy,

It seems that you aren’t the site collection administrator in the site collection as only the site collection administrator can see the Site Collection Administration section.

If you want to do from step 1, I suggest you can do the following.

Contact the site collection administrator and let him add you as the secondary site collection administrator via navigating to the SharePoint admin center>selecting the site collection he shared with you>Owners>Manage Administrators>typing your name in the Site Collection Administrators box. After that, you should take all steps above.

Since you can do step 4 and step 5, I think that you can add the document set content type and are granted the Edit permission by the site collection administrator, you don’t need to do from the step 1 and you should complete all the steps above.

So about “but then I am stuck again from step 6”, could you provide us with some related screenshots for our clarification?

Thanks,

Cliff  

* Beware of scammers posting fake support numbers here.

* Kindly Mark and Vote this reply if it helps, as it will be beneficial to more community members reading here.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Answer
Answer

Hi KatyMurray,

It is not feasible to show the column Date Picture Taken in each subfolders and not show it in the primary folder now.

As a workaround, you can temporarily change the view in the page where the primary folder exists to hide the column Date Picture Taken when navigating to the page and then change to another view to show the column Date Picture Taken when entering the subfolders.

 

Thanks for your understanding,

Cliff

Hi Katy,

You can add a new custom library including the document set content type with a welcome page view which is different from the library default view to achieve your requirement.
Here are the steps in my environment.
1. Navigate to a site collection in SharePoint Online.
2. Click Site settings>Site collection features under Site Collection Administration and ensure that Document Sets is activated.
3. Create a custom library named test.
4. Click Library settings>Advanced settings>Yes under Allow management of content types to make the library test be allowed to add a content type.
5. Click Settings>Site settings>Site content types>Create>Name the document set content type document set 1>selecting Document Set Content Type under Select parent content type from>OK.

6. Return to the library test>Library settings>Add from existing site content types>selecting document set 1>Add>OK.
7. Click New to add two document sets named picture 1 and picture 2.
8. Drag the pictures you want into picture 1 and picture 2.
9. Return to the library test>Library settings>Create column>naming the column name Date Picture Taken>selecting Date and Time under The type of information in this column is>selecting Date & Time under Date and Time Format>OK.
10. Return to the library test>Library settings>selecting All Documents>unchecking the column Date Picture Taken if it is checked>OK>clicking Create view>Standard View>naming the new view document set view>checking the column Date Picture Taken>OK>clicking document set 1>Document Set settings>selecting document set view under Select View in Welcome Page View>OK.

11. Return to the library test and you should see there is not the column Date Picture Taken in its view. When you enter picture 1, you will see the column Date Picture Taken. Then you can select one photo to edit the column Date Picture Taken.



Thanks,
Cliff
[Updated by Cliff MSFT at 22:27 PM on October 6, 2016]

* Beware of scammers posting fake support numbers here.

* Kindly Mark and Vote this reply if it helps, as it will be beneficial to more community members reading here.

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated May 14, 2021 Views 535 Applies to: