SharePoint Online site columns not appearing as a crawled property

Hello,

I have created a list made up of custom site columns, each of which is a Single Line of Text with a maximum of 255 characters.

 

After 24 hours the properties have still not appeared in the list of Crawled Properties available via /_layouts/15/listcrawledproperties.aspx?level=sitecol. They also do not appear in the list of Crawled Properties available via SharePoint Administration (Classic version) where the tenant-level settings are.

 

I have followed the advice of this post, and marked the list and site for reindexing, but that did not work either: 

https://support.office.com/en-us/community?threadid=d7e5a369-15c1-44d0-827d-604ea00d4237

 

I have followed the advice of this blog post as well 

https://asishpadhy.com/2018/11/06/fix-for-site-column-not-showing-up-in-search-crawled-properties-in-microsoft-team-sites/ 

I have found the columns in the list of ManagedProperties and CrawledProperties that are returned in XML when you call the search api and specify the ManagedProperties and CrawledProperties in the refiners query string parameter. I have also performed searched against these properties

I have viewed the crawl log and seen that the items featuring these custom columns have all been crawled.

 

I have also verified the settings on Site Settings > Searchable columns, and Site Settings > Search and offline availability

 

I have checked that the all of my services are healthy via the Service health section of the Microsoft 365 admin centre.

 

However, despite all of this, the properties still do not appear in the Search Schema UI, which would then allow me to map the properties to RefinableString managed properties so that I can use them for refining search as well as performing search operations.

 

I created the list on Thursday 20th of June 2019, and as of now the properties have not been created.

 

Could someone please contact me to look into this issue?


Thank you.

|

Hi James,

 

We’re sorry for the inconvenience caused by the problem.

 

As you have tried the most possible suggestions and still couldn’t search the contents in the List, can you please provide the following information for moving further:

 

a. Does the problem happens to specific List or all the Lists in the SharePoint site?

b. Can you create a new list and check whether you can search the content in it?

c. Does the problem happens to specific site or all the sites in SharePoint Online?

 

Appreciate your patience.

 

Regards,
Chitrahaas

 

--------------------------------
* Beware of scammers posting fake support numbers here.
* Kindly Mark and Vote this reply if it helps, as it will be beneficial to more community members reading here.

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hello Chitrahaas,

Thank you for picking this up.

a. There are custom lists that were made months ago in which the associated columns do appear in Crawled Properties.

b. I have created two lists, each with three columns. I have added data to both lists. Each list is on a different existing site collection: one classic, one modern. 

c. See b.

I will report back in 24 hours regarding whether any of the new content has appeared in Crawled Properties, at which point we should have answers to all of your questions.

Thank you,

James

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hi James,

 

Thanks for writing back and appreciate for your time to test the information asked in our previous reply. We will wait for your result and feel free to post back at your convenience.

 

Regards,
Chitrahaas

--------------------------------
* Beware of scammers posting fake support numbers here.
* Kindly Mark and Vote this reply if it helps, as it will be beneficial to more community members reading here.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hello Chitrahaas,

The site columns created yesterday have appeared as crawled properties. Initially the ones that I created a few days ago still hadn't appeared, then to further experiment I changed the Privacy settings in Site information from Private to Public, and now the initial properties have appeared! This is confusing, but at least it works now.

Thanks,

James

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hi James,

 

Thanks for writing back and letting us know. Glad to hear that you can search the content in the SharePoint List now. Based on my experience, crawled properties have nothing do with Privacy settings in the Site Information. So, even if you change back the from Public to Private, you should be able see the crawled properties. If you encounter similar issue in future, feel free to post back and we will try our end best to resolve the issue.

 

Thanks,
Chitrahaas

--------------------------------
* Beware of scammers posting fake support numbers here.
* Kindly Mark and Vote this reply if it helps, as it will be beneficial to more community members reading here.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hello Chitrahaas,

I switched the Privacy Settings back to Private and then the crawled properties disappeared again. So I switched it back to Public so I could get on with my work, but it would appear that the problem persists, it is just something that I can work around for now.

Thanks,

James

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hi James,

Thanks for letting us know and we request you provide some more time for involving more resources about this problem and will post back as soon as there is an update from our end.

Regards,
Chitrahaas

--------------------------------
* Beware of scammers posting fake support numbers here.
* Kindly Mark and Vote this reply if it helps, as it will be beneficial to more community members reading here.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hi James,

Thanks for your patience, I have go through the thread carefully, and would like to provide my help here.

As Chitrahaas mentioned, we have involved the related resources on this issue. According to their opinion, as issue didn’t infect other list column's crawled properties. It should be related with the provision issue of this list at that specific time.

Thus, as a workaround, please consider back up your content in that specific list and migrate it to the other lists for further working.

If you prefer to work on the current list, then we might need to involve the related team to check the back-end.

Please let us know your decision.

We greatly appreciate your time and patience.

Regards,

Alex Chen

---------------------------------------------
* Beware of scammers posting fake support numbers.

* Kindly Mark and Vote this reply if it helps, as it will be beneficial to more community members.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hi James,

 

Haven't hear from you for a while. Please let us know if you still need help regarding to this issue.

 

Regards,

Alex Chen

---------------------------------------------
* Beware of scammers posting fake support numbers.

* Kindly Mark and Vote this reply if it helps, as it will be beneficial to more community members.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated January 25, 2021 Views 1,880 Applies to: