Quick Links Webpart on Modern Pages automatically appends ?web=1

Hello! I'm trying to get to grips with SharePoint communication sites / modern pages to create some staff/pupil dashboards. When using the Quicklinks webpart, SharePoint automatically appends ?web=1 to any URL that I set.

For example if I set https://www.bbc.co.uk as the URL, SharePoint creates the link as https://www.bbc.co.uk/?web=1

This is fine for websites that can ignore ?web=1 (BBC website ignores ?web=1 and displays correctly), but internally linked URL's can't cope with ?web=1, and display errors.

Is there a way to change the behaviour of the modern Quicklinks webpart so it no longer appends ?web=1, or is there a way we can configure IIS on our internal website webservers to ignore ?web=1 ?  Or any other suggestions?

I know there are other options easily for adding links to modern web pages with mixed results ("Link" webpart, embedded web link in "Text" webpart), but I really like the Quicklinks webpart if I could get passed this minor problem!

Grateful for any suggestions.

|

Hi P.shaw,

 

To better understand the situation, we'd like to confirm the information below:

 

1.For adding link to the Quick links web part in communication sites, did you do the steps below?

go to the communication site>click Edit in the top right of the page>hover the mouse above or below an existing web part>click the circled + > then select the Quick links web part > click " + Add "

 If not, please provide your detailed steps.

 

2.In the page below, please clarify which option on the left  you choose.

3.Regarding  "When using the Quicklinks webpart, SharePoint automatically appends ?web=1 to any URL that I set.

 

For example if I set https://www.bbc.co.uk as the URL, SharePoint creates the link as https://www.bbc.co.uk/?web=1"

 

Please provide some related screenshots to describe it.

 

4.Does the issue happen to a specific communication site?

 

 

Regards,

Tina

--------------------------------
* Beware of scammers posting fake support numbers here.
* Kindly Mark and Vote this reply if it helps, as it will be beneficial to more community members reading here.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hi Tina - thanks for helping. In response to your questions:

1. Yes - that's the route I take.

2. When I get to that screen, I choose option "From a link" because the site I want to link is not in Office 365/SharePoint.

3. Here are some screenshots...

4. This problem affects any modern site that I create, including communication sites.

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hi P.shaw,

 

Thanks for your updates and detailed information.

 

We'd like to explain that there is no out of box feature to change the behavior of the modern Quick links web part to prevent it from appending ?web=1 to the URL.

We appreciate your understanding.

 

Besides, for "This is fine for websites that can ignore ?web=1 (BBC website ignores ?web=1 and displays correctly), but internally linked URL's can't cope with ?web=1, and display errors."

Regarding "display errors", is it an access required permission error? Please also provide a related screenshot of it.

 

Thanks,

Tina

--------------------------------
* Beware of scammers posting fake support numbers here.
* Kindly Mark and Vote this reply if it helps, as it will be beneficial to more community members reading here.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hi P.shaw,


Did you refer to the reply above? Feel free to let us know if you need further help.

Regards,

Tina

--------------------------------
* Beware of scammers posting fake support numbers here.
* Kindly Mark and Vote this reply if it helps, as it will be beneficial to more community members reading here.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Thanks for the reply Tina. That's a shame. One example I can give is our print-authorisation URLs. They should look like this:

But when followed from a "Quick links" webpart, they look like this:

I've done a bit of research and I think I can probably use the "URL rewrite module" in IIS Admin to tell our internal webservers to ignore the ?web=1 addition to URLs. However, I've never used the URL Rewrite Module, and i's beyond the scope of this discussion group,. Wish me luck! Thank you for your help so far though Tina.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated February 18, 2021 Views 1,629 Applies to: