Getting error "Sorry, you don't have access to this page" in SharePoint online, while doing navigation settings.

In SharePoint Online i had logged in with Office 365 admin & Site owner.

 Site contents > Site settings > Navigation. 

I changed the navigation settings but unable to save and getting error "Sorry, you don't have access to this page".

Answer
Answer

Hi Abhishek,

 

 

Thanks for your updates.

 

Please make sure custom script is enabled in SharePoint online.

Go to SharePoint Admin center>settings>Custom Script

If it shows the Prevent option, please follow the steps below to enable scripting.

1.Download and install the SharePoint Online Management Shell

 

2.Run the commands

set-sposite https://contoso.sharepoint.com -denyaddandcustomizepages 0

 

For your reference:

Note:

1.For connecting to SharePoint online, please type https://contoso-admin.sharepoint.com which is the URL of your SharePoint Admin center

2.You need to change contoso with your own tenant.

 

 

Then please sign in to the SharePoint site, follow the steps in the original article to enable managed navigation for a site in SharePoint and check the result.

 

 

 

Thanks,

Tina

--------------------------------
* Beware of scammers posting fake support numbers here.
* Kindly Mark and Vote this reply if it helps, as it will be beneficial to more community members reading here.

6 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 
 

Question Info


Last updated September 17, 2020 Views 4,700 Applies to: