Stop Skype for Business from Starting Automatically

I made the mistake of opening skype for business once and now this gods forsaken malware won't stop launching when I log in.  I disabled it from the startup screen in the task manager and went into the options menu for skype business and unchecked both "automatically start the app when I log in to windows" and "start the app in the foreground" but it keeps doing both, and now I'm told I can't uninstall it without uninstalling my entire office suite.  Please help me get this virus off my pc.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

I fixed it but by using task manager to show the location of lync.exe, killed it, then deleted it. Now of course this only works if you never use Skype for Business. 

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I had this problem and tried the settings in the app and Windows Startup before finding what I think was the final culprit. Windows now tries to reopen all programs that were open when the computer was last turned off; this includes Skype for Business unless you explicitly exit the program (not just minimize it to the toolbar which is the default behavior of "closing" the app). This setting for reopening apps can be turned off in the Control Panel.

Control Panel -> Accounts -> Sign-In Options -> Uncheck "Use my sign-in info to automatically finish setting up my device and reopen my apps after an update or restart."

11 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Daniel Wehrle provided excellent advice which seems to have helped me! Upon reboot, Skype for Business does not any longer nag me for a password several times during the day. One correction: In Windows 10 Pro the first step didn't work for me. There is no ACCOUNTS option in the control panel. But I just clicked the WINDOWS icon (or pressed the WINDOWS key) and then typed in "sign-in options" which provided a search result right at the top. I clicked that search result and found the dialog box provided by Daniel. This WORKS!
Professor

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I have Office 2016 installed and tried everything to stop Skype for Business starting up. Nothing worked for me until I did this:

(1) Install the Office Deployment Tool (ODT) from this link to a folder on your computer:

https://www.microsoft.com/en-us/download/details.aspx?id=49117

(2) Create a file with Notepad called configuration.xml in the same folder as the ODT files that contains the following:

<Configuration> 

 <Remove>

  <Product ID="SkypeforBusinessRetail" > 

   <Language ID="en-us" /> 

   </Product> 

 </Remove> 

<Display Level="None" />

</Configuration>

(3) From DOS command prompt in folder where both the ODT files are type this:

./setup.exe /configure configuration.xml

(4) Wait for the command to complete, then restart Windows and check that Skype for Business no longer comes up.

I hope it works for you too!


Anthony.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I found a solution....

Switch to Linux and tell Microsoft to go **** themselves with their applications that start automatically after you tell them not to.

13 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hey,

This fixed the issue for me. Check if your Skype for Business is still running in Task Manager > Processes, before restarting your PC. If it is, end the task before restarting. Also make sure that you’ve unchecked the automatic start from the program and disabled Skype for Business from Task Manager > Start Up, which I’m sure you have at this point. If this doesn’t work, I also signed out and deleted my sign in info.

What seems to be happening is that if you leave Skype for Business running in the background the PC will bring it to the foreground on restart, the only way to make sure that it’s turned off is to check the Task Manager.

Not an official answer, just my input on the matter and how it was fixed for me. Hope this helps.

This solved my problem, thanks a million MrPopa. My head was wrecked trying to solve the issue and the answers from the Microsoft support weren't working

4 people found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

I spent time on the phone with a Microsoft representative who tried to help me but at the end said that there is nothing that he can do and directed me to this URL to post and voice my concern.

The representative was helpfull and provided good service, but we tried the different suggestions that some poeple already posted, but to no success.

I hope that there Microsoft solves this soon.  It is not something critical, but shouldn't happen and is disappointing.

Thanks.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

That's just funny dude, I like your reply! Lol

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

After LITERALLY trying every suggestion on this chain (well, except the move to Linux), nothing worked.

(btw, I have Skype for Business for Office 365 MSO installed ver. 16.0.11328.20220 32-bit )

I then decided to open Task Manager, right-mouse on the Skype for Business app, and BEFORE ending the task, I selected "open file location" [which causes File Explorer to open].  I then stopped it (on Task Manager), went back to File Explorer and renamed the Lync file.  Restarted the computer a few times and so far, seems to have worked. 

Microsoft....pretty disappointing that this thread has been opened for over a year and for something so simple, yet so frustrating, .... just UNBELIEVABLE!!!

1 person found this reply helpful

·

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hey,

This fixed the issue for me. Check if your Skype for Business is still running in Task Manager > Processes, before restarting your PC. If it is, end the task before restarting. Also make sure that you’ve unchecked the automatic start from the program and disabled Skype for Business from Task Manager > Start Up, which I’m sure you have at this point. If this doesn’t work, I also signed out and deleted my sign in info.

What seems to be happening is that if you leave Skype for Business running in the background the PC will bring it to the foreground on restart, the only way to make sure that it’s turned off is to check the Task Manager.

Not an official answer, just my input on the matter and how it was fixed for me. Hope this helps.

This solved the issue, pls people, in addition to the official Microsoft answers and procedures,, plse make sure the skype is not running at task manager/proceses/ and that yr mail is not wriiten at the login window.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

 
 

Question Info


Last updated December 3, 2020 Views 74,139 Applies to: