Users unable to log into Skype for Business on 1 computer

Dear All,

We are having a problem with one windows 10 computer that won't connect to Skype for Business.  The system gets as far as the user clicking the sign in button and then hangs from then on.  This happens with whoever tries to log into ****.  We have removed the sip folders, reinstalled the application, cleared the credentials manager all with no change to **** hanging at the sign in.  We do not get as far as having to enter the users password.  We can log into our Office 365 accounts fine on this computer and log into **** on other computers with no problem.

Here is the end of the Lync-UccApi-0-UccApilog log if it is of any help.

02/01/2017|09:35:28.186 2744:2FAC INFO  :: Function: CUccAudioMediaDevice::InternalInitialize
02/01/2017|09:35:28.186 2744:2FAC ERROR :: HRESULT API failed: 80004005 = hr. ParsePidVidMi
02/01/2017|09:35:28.186 2744:2FAC INFO  :: CUccAudioMediaDevice::InternalInitialize - DisplayName set to IDT High Definition Audio CODEC
02/01/2017|09:35:28.232 2744:2FAC TRACE :: CUccMediaManagerEventAdapter::OnMediaPlatformExEvent - Processed MPEMT_DevicePnpEvent.
02/01/2017|09:35:28.232 2744:2FAC TRACE :: CUccMediaManagerEventAdapter::OnMessage - Processed WM_MMGR_PLATFORM_EX_EVENT.
02/01/2017|09:35:28.232 2744:2FAC INFO  :: Function: CMediaDevice::InternalQueryDeviceLocation
02/01/2017|09:35:28.232 2744:2FAC ERROR :: HRESULT failed: 80070032 = hr . failed to get device property MM_DP_LOCATION
02/01/2017|09:35:28.232 2744:2FAC WARN  :: The video device doesn't contain location information
02/01/2017|09:35:28.232 2744:2FAC INFO  :: Function: CUccVideoMediaDevice::InternalInitialize
02/01/2017|09:35:28.232 2744:2FAC ERROR :: HRESULT API failed: 80004005 = hr. ParsePidVidMi
02/01/2017|09:35:28.232 2744:2FAC INFO  :: CUccVideoMediaDevice::InternalInitialize - Screen Scraper camera's location is 6
02/01/2017|09:35:28.232 2744:2FAC INFO  :: CUccVideoMediaDevice::InternalInitialize - Screen Scraper camera with no special marks
02/01/2017|09:35:28.232 2744:2FAC INFO  :: CUccVideoMediaDevice::InternalInitialize - Screen Scraper camera is marked as 'virtual'
02/01/2017|09:35:28.232 2744:2FAC TRACE :: CUccMediaManagerEventAdapter::OnMediaPlatformExEvent - Processed MPEMT_DevicePnpEvent.
02/01/2017|09:35:28.232 2744:2FAC TRACE :: CUccMediaManagerEventAdapter::OnMessage - Processed WM_MMGR_PLATFORM_EX_EVENT.
02/01/2017|09:35:28.259 2744:2FAC INFO  :: Null Microphone Present, returning false for IsSystemDefaultCommunicationDevice
02/01/2017|09:35:28.260 2744:2FAC INFO  :: IsInVDIDebugMode hr = 80070002, dwValue = 0
02/01/2017|09:35:28.261 2744:2FAC INFO  :: IsInVDIDebugMode hr = 80070002, dwValue = 0
02/01/2017|09:35:28.277 2744:2FAC INFO  :: IsInVDIDebugMode hr = 80070002, dwValue = 0
02/01/2017|09:35:28.277 2744:2FAC INFO  :: IsInVDIDebugMode hr = 80070002, dwValue = 0
02/01/2017|09:35:28.277 2744:2FAC INFO  :: IsInVDIDebugMode hr = 80070002, dwValue = 0
02/01/2017|09:35:28.277 2744:2FAC INFO  :: IsInVDIDebugMode hr = 80070002, dwValue = 0
02/01/2017|09:35:28.278 2744:2FAC INFO  :: IsInVDIDebugMode hr = 80070002, dwValue = 0
02/01/2017|09:35:28.278 2744:2FAC INFO  :: IsInVDIDebugMode hr = 80070002, dwValue = 0
02/01/2017|09:35:28.278 2744:2FAC INFO  :: IsInVDIDebugMode hr = 80070002, dwValue = 0
02/01/2017|09:35:28.279 2744:2FAC INFO  :: IsInVDIDebugMode hr = 80070002, dwValue = 0
02/01/2017|09:35:28.279 2744:2FAC INFO  :: IsInVDIDebugMode hr = 80070002, dwValue = 0
02/01/2017|09:35:28.280 2744:2FAC INFO  :: IsInVDIDebugMode hr = 80070002, dwValue = 0
02/01/2017|09:35:28.280 2744:2FAC INFO  :: IsInVDIDebugMode hr = 80070002, dwValue = 0
02/01/2017|09:35:28.280 2744:2FAC INFO  :: IsInVDIDebugMode hr = 80070002, dwValue = 0
02/01/2017|09:35:28.287 2744:2FAC INFO  :: IsInVDIDebugMode hr = 80070002, dwValue = 0
02/01/2017|09:35:28.287 2744:2FAC INFO  :: IsInVDIDebugMode hr = 80070002, dwValue = 0
02/01/2017|09:35:28.288 2744:2FAC INFO  :: IsInVDIDebugMode hr = 80070002, dwValue = 0
02/01/2017|09:35:28.578 2744:2FAC INFO  :: CUccServerEndpoint::Initialize - Using the compression Setting from Regkey(Default is UCCSCS_ALWAYS_ENABLED): 1
02/01/2017|09:35:28.578 2744:2FAC INFO  :: CUccServerEndpoint::Initialize - This endpoint is  sharing presentity data.
02/01/2017|09:35:28.606 2744:2FAC INFO  :: CUccEndpoint::put_TelephonyTypewrite - Set TTY enabled to false
02/01/2017|09:35:42.613 2744:2FAC INFO  :: SIP_REGISTER::Unregistration already in unregister/ed state (0), this [150D4CD0]
02/01/2017|09:35:42.619 2744:2FAC INFO  :: SIP_STACK::DeleteSipEndpoint deleting sip endpoint 150D4698, this 14BE1BF0
02/01/2017|09:35:42.630 2744:2FAC INFO  :: SIP_ENDPOINT::Shutdown (150d4698) Shutdown
02/01/2017|09:35:42.647 2744:2FAC INFO  :: CUccDnsResolverManager::Stop MR-INFO - [150D3C60] DNS resolver manager stopped
02/01/2017|09:36:08.459 2744:2FAC INFO  :: CUccServerEndpoint::Initialize - Using the compression Setting from Regkey(Default is UCCSCS_ALWAYS_ENABLED): 1
02/01/2017|09:36:08.459 2744:2FAC INFO  :: CUccServerEndpoint::Initialize - This endpoint is  sharing presentity data.
02/01/2017|09:36:08.459 2744:2FAC INFO  :: CUccEndpoint::put_TelephonyTypewrite - Set TTY enabled to false

Any help would be appreciated.

Kind Regards

James

Answer
Answer

I have now managed to resolve the issue.

The reason Skype for Business wasn't connecting was because the computer didn't think it was connected to a network, even though it was.  In the Network & Sharing Center it said that "You're currently not connected to any network". 

After some research it was suggested that the issue was caused by an update that changed the settings on a registry key.  After downloading Process Monitor it turned out that the nlasvc service (run as the user Local Service) was not allowed read/write access to 'HKLM\software\microsoft\windowsnt\currentversion\networklist\profiles\' in the registry.  After adding in this user and giving it permission the Network and Sharing Center then showed as connected to a private network and Skype for Business then worked.

Thanks

James

16 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 
 

Question Info


Last updated May 25, 2020 Views 5,071 Applies to: