Skype for Business cannot be selected to use the default url:skype protocol

Skype for Business cannot be selected to use the default url:skype protocol or URL:Call to protocol.

I have Skype for Business installed.

i also have skype preview installed (windows 10 anniversary edition)

It seems skype preview has overtaken most of the protocols and will not allow me to change them to skype for business.

Does anyone know if this is by design or a bug?

Or does anyone know of a workaround/registry hack to enable me to use skype for business?

 

Question Info


Last updated October 7, 2019 Views 8,121 Applies to:
Answer
Answer

Hi Tony,

 

Thanks for your reply.

You cannot use Skype Preview to login Skype for Business account. And Skype for Business use Lync protocol, such as Skype for Business 2016 use “URL: lync 15 protocol” However, Skype use “URL: Skype Protocol”, which is set by default. What you can change is set the default app for Tel Protocol. Here are the steps:

 

Go Control Panel—Programs---Default Programs—Set Default Programs—Select Skype for Business—Choose defaults for this program--Select the Checkbox next to TEL and click Save

.

And then check the Windows registry to see the handler of a registered protocol

 

Go Registry Editor----HKEY_CLASSES_ROOT----sip---DefaultIcon—double click the default value and make sure the value data is shown as below:

I suggest you use the method above to check the related settings and then use Skype for Business to login your Skype for Business account.

 

Regards,

Alison

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.