Powerpoint 2016 videos not playing on secondary monitor

I am using the release version of Powerpoint 2016 (16.0.4229.1024) with Office 365 Home under Windows 10 Pro 64-bit. When I embed a 'video on my PC' it will not play if displayed on a secondary monitor or a projector. If I change Slide Show/Monitor from Automatic to Primary Monitor then they do play. I have tried MP4 and MOV videos and neither play on the secondary monitor. I have tried clicking on both the video on the play button. They all play on the secondary monitor if run the same presentation under Powerpoint 2013 and they all play if I double click on the file under Windows (using 'Films &TV').

 

Question Info


Last updated November 20, 2019 Views 28,355 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hello,

Welcome to Microsoft Community and thank you for posting your query.

Please provide more information before we proceed.

1) What is the screen resolution of both primary and secondary monitors?

2) When you play the video using Film & TV app, are you playing it on Secondary monitor?

Please reply us with the information asked for further assistance.

Thank you.

8 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

The primary monitor is 2560x1440 and the secondary is 1920x1200. I have the same problem if I set the secondary to lower solutions such as 1024x768. If I swap 'Presenter View and Slide Show' under Display Settings during the slide show (so the presentation is on the primary monitor) it still will not play. If I switch off 'Use Presenter View' then it works on the primary monitor but not on the secondary monitor. If I switch on 'Use Presenter View' then it works if I select primary monitor but not if I select the secondary monitor.

I also get the problem when I use a projector as the secondary monitor. I am wondering if it is some interaction between PowerPoint 2016 and the video driver. The primary monitor uses an Intel HD Graphics 3000 driver and the secondary monitor a 2GB NVIDIA GEFORCE GT 540M GR. However, it all works fine with PowerPoint 2013.

The Film & TV app will play all the videos on either monitor at any resolution without problems.

5 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

The problem is still not resolved. Videos play on the primary monitor but not on the secondary.

19/03/2016 issue still not resolved. If I select Slide Show/Monitor/Automatic or Secondary it does not play videos, if I select Primary it does. So I select Primary to test my presentation. When I give the presentation it is on a tablet running Windows 10 with a remote projector and this does play. In other words I have a workaround for my setup.

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hello,

Welcome to Microsoft Community and thank you for posting your query.

Please provide more information before we proceed.

1) What is the screen resolution of both primary and secondary monitors?

2) When you play the video using Film & TV app, are you playing it on Secondary monitor?

Please reply us with the information asked for further assistance.

Thank you.

Parth,

Any updates on this?  This issue is still unresolved.  Things seemed to have worked for me fine under PP 2016...  but now, suddenly, I can't get the videos to play on the secondary monitor.  Has anyone been able to track this issue down or found a solution?

Thank you!

5 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hello,

Thank you for your reply.

I understand the inconvenience caused to you. I suggest you to try to install the updates using the steps mentioned in the following Microsoft Community article and check if it resolves the issue.

https://support.office.com/en-us/article/Update-Office-and-your-computer-with-Microsoft-Update-2ab296f3-7f03-43a2-8e50-46de917611c5

Hope this helps. Please post back with the updated issue details for further assistance.

Thank you.

5 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thank you for your suggestion. I always install the latest updates automatically. I double checked Windows is up-to-date and installed the latest GeForce driver but the problem remains (videos play if the Slide Show: Primary monitor is selected but not if the Slide Show: Secondary monitor is selected).

4 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi, I only came across the same issue very recently. If you haven't already resolved it already, try this...worked in my situation.

If videos play in edit mode but fail to play in Slide Show...

The Slide Show ‘Hardware Acceleration’ option MUST BE DISABLED (check-box ticked) in PowerPoint Advanced Options. The video will then work in Extended mode using Presenter View! The click-route is below…

 

PowerPoint 2016>File>Options>Advanced>Display>Disable Slide Show hardware graphics acceleration (ticked)

I must credit a fellow audio-visual professional technician for suggesting this...

All the best...

128 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi, that solved the problem. I have been using the workaround so I had forgotten about it but it is more convenient to work with my monitors the other way round (presentation on secondary). 

Thank you for posting and thank you friend for suggesting it. As I suspected, it is probably the  NVIDIA GEFORCE GT 540M driver but I didn't think of disabling the graphics accelerator.

8 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

You might want to consider installing the latest version of the Nvidia driver too from their site. I think they released one just a few days ago.
www.pptalchemy.co.uk

6 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks, I always install the latest but up to now it hasn't fixed this particular problem. In fact, the previous 15th August 372.54 version started crashing W10 for the first time. I hope the latest (30/8/2016, 372.70) fixes both problems.

Update: the latest NVIDIA driver 30/8/2016 372.70 fixes the problem and videos will now run without disabling the graphics accelerator. So far W10 has not crashed either.

Update 2 (12/09/2016): unfortunately Powerpoint is still blue screening Windows 10 with IRQL_NOT_LESS_OR_EQUAL which I guess is the NVIDIA driver in 'Presenter View'. It happens on an irregular basis every few days and I cannot reproduce the problem consistently. It never happened before release 372.54.

8 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.